85
questions

Need to change timing belt & h2o pump, do brakes, and change plugs. +/- $2,000. Would it be better to fix it, or trade it for a similar 2001-2004 4-Runner with 140,000 to 150,000 miles and spend the $2,000 on the next car?

I RECENTLY BOUGHT MY 4RUNNER. WHEN I GOT IT I NOTICED RANDOMLY A BURNING SMELL WOULD COME FROM UNDER THE HOOD, NEVER ANY SMOKE THOUGH. I CHECKED TO MAKE SURE NOTHING WAS LEAKING WHICH IT ISNT. NOW THE SMELL IS MORE FREQUENT AND STRONGER. AND I NOTICED TODAY WHEN I ACCELERATE IT FEELS LIKE MY TRUCKS STRUGGLING A LITTLE.

They just tested with a ome meter the Vacuum Air inTake meter it is registering 250, does it need to be replaced. If not wwhat can be the issue? all of the hoses are new.

and having a steering rack replaced, does it include the lines?

In the article about "Fuel Syatem Too Rich" there is a section on determining if the MAF is faulty. Part way down the paragraph, the statement is made.... (These conversion tables will help.) The conversion table are for calculating Barometric Pressure for elevation. Where do I find these conversion tables? I need to evaluate the parameters of my MAF to see if it is faulty because I keep getting a P0171, Too lean code and I can not find any vacuum leaks. Thank you

i have replaced the cat. converter up front, fuel filter, plugs, wires & more. I even had it in the shop for 2 days & still cant find the problem!?? it shows a code for the sir flow mass sensor but when it was replaced it is still doing the same..NO power!

The rear end will sometimes bottom out when going over a bump.

i have to move the shift lever to get it to start

When I turn from a stop I believe I hear something not catching. This problem just started. It is just like driving a manual transmission with a clutch that is gone. This happens when I am at a stop and then go, once I get going I from anywhere from 20mph-40mph (I have n0t tried pushing it past that)and step on the gas to speed up it has that slipping feel

the car started running rough at about 46mph, mechanic found a cracked spark plug and put in new ones. 3 weeks later, same symptoms..running fine until about 46mph and then real rough and then smooths out. curious about costs

When I hook up my boat trailer I get all lights on left side of trailer, but only tail lights on right side, no turn signal or brake lights. Went under truck and stripped a litte wire and and tested, no voltage to green turn signal light. Yellow, left side is good. Is this a broken wire at some point or other harness issue? Took 4 runner tail lights out to look for wiring harness attachment no luck, is it buried under a panel somewhere? thanks

the heater control screen in very dim, can you change bulbs?

the window on the rear passenger side does not go up or down

Need to drain oil after putting too much in and cannot see/find oil cap under truck, is there a plate or something I need to remove to get to it and the oil filter? Any pics?

Added too much oil, now blowing white smole especially tail pipe...toyoa 4runner..diagnosis?