where is the harness connection for the fuel pump wiring?

it will run good for about 30 sec and then the light pops on and it runs like its not getting gas you can hit the gas pedal or nothing thanks

My brake light has been replaced, I've checked the wires and the connections all look fine. When I turn on my lights all the lights come on, when I press on the brakes the brake light on the rightside goes out. I don't understand it, I am trying to fix it myself because if I go to the dealership they'll see me a just a woman who knows no better and want to charge me some crazy price for something that might be simple to fix.

I had my head gaskets replaced and when I spoke to the mechanic he said the fuel pump would work if he wired it to the battery, but not on it's own. He thought I needed a new computer. I installed on and the problem still exists.

I was told when the check engine light came on suddenly 8 yrs ago that Suzuki's were programmed/set to do so, to remind you of 75k maintenance, which I had already done at 50k. (I have taken REALLY good care of my Sidekick, and it has been a really good car, want to keep til it falls apart. But last few years some repairs in the 400-600 range, about one of those per year, incl tune-ups and so on.) Well, the light popped on again and I noticed it shortly after 150k miles. Coincidentally I had just had the exhaust pipes all replaced and the AC recharged. Thanks! May be ready to sell this car b/c I really need a 4WD for winter here--lots of ice storms.

My car started making a scraping, rattling, faintly screeching noise when running, esp after sitting a while. Diagnosed as bad AC bearings. I just had the AC recharged due to a slow leak, didn't have time or money for leak location/repair. This was a mo. ago. Any possible connection? I can only find estimate for compressor, condensor and evaporator here---all beyond my means. But my only way to get to work!

door has to be manually lifted to close.

i got the car a couple of weeks ago and it was running good. then i took it out for a drive one day and it just started running like crap. the rpm's wouldnt go above 3000 and there was no power. the check engine light comes on and the o/d off light blinks. hope someone can help me

Sometimes when it cold out 10 degrees or colder while driving there is a noise on the driver side and in front of the driver. It like a low pitch whine. When it gets warmer I do not hear it. Sometimes I can feel it in the steering wheel when the whine starts. The noise does not happen all the time.