13
questions

i look with a mirral inside the hole what sure i do

i look with a mirral inside the hole what sure i do

I bought this car in January of this year and the lights worked well for about 7 weeks. Then one night I got in to go to work and they didn't come on. This is an issue because I work graveyard shifts and need to see in the car before I get in.

A month after I purchased my car the Check Engine Light came on and it started running extremely rough. I found out later that I was running with no Oil and that Impreza's had the problem of burning oil. I just want to know if there is anyway I could get it fixed under warranty or recall because I have no way of coming up with 3.5k to buy a new engine and get it installed. I bought the car to get to and from work, its useless if I cant do that.

plug #3 is misfiring

brought it to a mechanic he replaced the relay for my motor blower resistor didn't work . we bridged the wiring and the fan speed works on 1-4 when it is bridged still not able to use the recirculating, a/c, or rear defroster buttons.could it be a bad switch for the fan speed and all of my buttons? thought about maybe making a toggle switch for the heat to come out when needed.

last weekend a/c compressor went bad (loud sound like metal to metal grinding almost, when the fan was off it was still running like it hadn't disengaged from what it was doing, when the fan was on it muffled the sound a little not by much though), resulting in the belt snapping, which is not an issue to me at this time. shortly after the compressor started going crazy my fan crapped out on me doesn't work on any speed no heat is coming out of it at all. My rear defroster, a/c, and recirculating air buttons do not work . its a manual fan 0-4 i've checked fuses tried to find the relays and checked under my glove box to see if the motor blower resistor is shot . if anyone has any information as to what it could be id appreciate it .

the car drives fine i bought it in april of this year had to replace the fuel pump in july after making a trip to PA from ME. i have since made another trip to PA. on my way down i noticed it was bogging out when approaching either a stop light or stop sign or when i release the clutch . other than that the car drives perfect . i was thinking maybe it need a tune up or a new alternator ? it idles down past 1 on the tac but not below 0 it goes to the dash bewteen 0&1 so .5 ? once it does that it spurts back up to around 1 when ive completely stopped. not really sure whats going on with it just looking for some insight . i was going to get some new spark plugs and wires soon and try that work my way up do a process of elimination

took it to autozone and ran codes. said it was and o2 sensor. also ran codes from a different machine which indicated something about left bank heater? everything was fine until i had the clutch replaced.

I have 2008 Subaru Impreza and my intermittent wipers are not working. The wipers also do not return all the way down when turned off but stay in the middle of the windshield. The Hi and Lo speeds are working fine.
I had a problem with the nut for the driver side wiper arm being loose.
I tightened the nut and the wiper works. After I fixed the loose nut problem I started having problems with intermittent mode. Since we are having lots of snow having wipers work would be very nice. Your advice greatly appreciated

My Subaru is 3 years old with 38,000 miles on it; I do mostly hwy driving to work. When taking it in for inspection, I passed but was told my front brakes are low, and they are bearing the braking load. Mechanic told me that rears "look almost brand new" because fronts are stopping the car. Is this normal or a defect?

I have 2008 Subaru Impreza and my intermittent wipers are not working. The wipers also do not return all the way down when turned off but stay in the middle of the windshield. The Hi and Lo speeds are working fine.
I had a problem with the nut for the driver side wiper arm being loose.
I tightened the nut and the wiper works. After I fixed the loose nut problem I started having problems with intermittent mode. Since we are having lots of snow having wipers work would be very nice. Your advice greatly appreciated.