14
questions

I don't drive often and I worry that my tires will get flat spots or go bad because of this.

I've had 2 break in less than 2 years. I don't drive much so this seems excessive for the mileage I'm putting on the belt.

When this happens the brake lights don't work.

I cannot shift into reverse at all. First gear is also very hard to shift into.

I have an '07 Impreza 2.5i w/ 67k. Lately I have experienced two things. 1. a grunting from the suspension on take offs and stops and 2. a chirping or whining under acceleration that stops with the upshift. No codes. have checked and fixed heat shields and tried temporary silicone to isolate grunt as there are no greaseable fittings.

would it be less costly to get the motor rebuilt, it has a flood/salvage title. the engine turns, but wont turn on

it had previous fresh water flood salvage title. the engine turns, but does not turn on, what can i do to fix the problem?

axle bearing making ruff sound

she was driving in the rain in the mountains and the light came on and a noise in the back. she and her son are alone on the road

left rear wheel bearing makes noise. I am thinking it is a press in bearing not a bolt on type

I pulled the door panel and went to remove the switch and pulled it apart in the wrong spot . It looks like spagetti lol

Even when I turned off the engine and remove the key from the ignition

There is a slight clicking sound in the selector lever when you move the shifter in and out of Park. There is also a click in the passanger side dash when you turn the hedlights on. What is this, and is it normal or a problem? If so how do i go about getting it fixed?