8
questions

With everything plugged in my Subaru revs to 7000 rpms and stays there when we unplug the idle air control sensor it revs inbetween 500 and 2500 rpms. I replaced the idle air control sensor and the tps and its still doing the same thing. Any ideas what could be wrong?

When accelerating, the automatic transmission smoothly shifts from 1st to 2nd, but won't go into 3rd. Instead, it winds up the RPMs, makes a loud popping sound, and lurches. Is this necessarily an expensive transmission issue (which would 'total' this aging car), or possibly something more easily repaired?

It shows check engine and stops on its own, have to start it and it will move and stop again, until three starts then it runs. There is a feeling of misfiring. Sometimes when the fuel is low, it just stops any time. Sometimes it runs very smoothly, but sometimes, it just stops. There is a smell of burning oil when the cars is stationery. Please advise

car still seems to run ok

a lot of fresh oil in no 1 and a little in the rest

THE LEFT SIDE OF MY HATCH BACK DOOR LEAKS WATER IN WHEN IT RAINS. i'VE HEARD THERE IS A PROBLEM WITH THE RUBBER SEAL. iS THERE A REPLACEMENT PRODUCT AVAILABLE

Feels like I am riding in a truck. Has the rim replaced, new tires. still feels bounce like riding a horse lots of vibaration in the rear of car

battery is new but not getting power to start engage wire on solenoid.Can us a remote stater switch to start with key on. Turn the key to start and you hear clicking and the indicator lights come on. tested clutch switch good. no blown fuses. continuity on starter feed wire. any ideas?