Dead Battery Due to ABS Pump Not Turning Off on Chevrolet Tahoe

The anti-lock brake system (ABS) pump may stay running after the ignition is turned off causing the battery to go dead. Our technicians tell us that the ABS control module should be replaced to correct this fault.

RepairPal Verified
Average mileage: 147,703 (94,159–220,000)
5 model years affected: 2000, 2001, 2002, 2003, more2004
17 people reported this problem
8 people shared problem details
2004 Chevrolet Tahoe150,000
Same problem as above with the pump running after the car is turned off. Mechanic told me it was the ECBM control module. Gm wants $1100 but you can get them rebuild for as little as $150. Do a google on ECBM module repair.
2 people like thisFlag inappropiate
abs light on and a pump or motor staying on after engine turned off. also battery going down, fuel gauge reading,a quarter of a tank one minute, then a half a tank within seconds, with motor running in park. abd idle very low. very unusual problems at once. is this a abs module problem?
1 person likes thisFlag inappropiate
This is the issue that brought me to this site. Just happened today and had no idea what that noise was. Looks like it's going to be expensive.
1 person likes thisFlag inappropiate
Tahoe battery dies after a week or so of normal use. New battery, new alternator: all replaced since this issue started. Mechanic can't figure it out.
I SENT MY ABS MODULE IN TO BE REPAIRED, WAS SENT BACK TO ME SINCE THEY COULDN'T FIND ANYTHING WRONG WITH IT. I HAVEN'T HAD AN ISSUE SINCE RE-INSTALLING IT..
Fan running after car is turned off and abs light has been coming on
2002 Chevrolet Tahoe125,320
pump will not stop running
2000 Chevrolet Tahoe137,433
abs lights is on
Related Items:
Im having trouble with low idling, would like to start with the simple things 1st. How do i ide...
i can be driving sometime for a few minutes or a few hours and for no reason the ABS light will...
When I begin to drive my suv the brakes will scrub and seem to fail. It does stop it feels like...
Actuator.control module encoder transfer case rebuilt can hear encoder working there is some mo...
I had a lot of metal to metal front end noise and bound up in changing from 2WHI to 4WHI and my...

Related Content