37
questions

My mom gave me the car. She had some backyard mechanic replace the ignition a year ago. Since then, it has been having problems. It won't start some days, after sitting for a day then it will start. It wont start sometimes and you have to wait for the security light to shut off then it starts. Last time it died for them, the dome light was flickering and the windows wouldn't roll down. It has only done this a few times to them. I was driving it to work, went to roll the window down and the car just died. It turns over and sounds like it wants to start but wont. My mom thinks it has to do with the guy who replaced the ignition. ANY help would be greatly appreciated!!! Thank you!

seems to be either starved or flooded with fuel.

seems to either be starved of fuel or to much.

some wires were pulled down and the plastic broken but where the key
goes is ok will the whole column have to be replaced

Applied the brake today, heard a sound like a piston crunching against a rotor, this is when the anti lock brake light and traction control off lights both came on. I can tell the traction control is not working properly now, the brakes seem fine. Any suggestions on what the problem might be? And how do I fix it? (everything was fine before this.) The car has just over 100k miles on it.

grinding is the telltale sign

The security light is on and its not blinking what do i do




Smooth acceleration up to 60mph. Then the car "JERKS" as if your pressing "ON the gas-OFF the gas." Twice per second, over & over & over. At the same time the RPM gauge is fluctuating "FROM 2000 down to 1500" then back to 2000rpm over & over & over. Until finally it jerks itself up to around 65-70mph. before it smooth's out again. Happens sooner going uphill under load. Also when there is more than two people in the car. NO CODES OR LIGHTS ON DASH CLUSTER...? Very frustrating! please help...

Smooth acceleration up to 60mph. Then the car "JERKS" as if your pressing "ON the gas-OFF the gas." Twice per second, over & over & over. At the same time the RPM gauge is fluctuating "FROM 2000 down to 1500" then back to 2000rpm over & over & over. Until finally it jerks itself up to around 65-70mph. before it smooth's out again. Happens sooner going uphill under load. Also when there is more than two people in the car. NO CODES OR LIGHTS ON DASH CLUSTER...? Very frustrating! please help...

A few days ago was driving down the road and car stopped on me and wouldn't start. Tried to jump start it didn't work. Came back the next morning tried again still wouldn't start. Took battery off and took to O'Reily's and they charged it, it was at 19% but its good. Tested the alternator its good so next step voltage regulator but don't know whereit is.

serpentine belt will not go on without taking off engine mount and bracket. Is this standard procedure or am I doing something wrong?

This is related to the car not starting issue. Key is in, lights come on but it will not crank. Not even a click from the starter. Battery is at full power, tested with a meter