72
questions

I put a head gasket on my sentra,everything seems fine,it runs fine when its in park and you accelerate but when you drive it it has no power,I changed the spark plugs ,the compression checked ok,when I visually check the fire it seems more of a yellow color instead of blue. Does anyone have any suggestions? Thanks

And is the wiring diagram the same for both? And where can I get one? I prefer texts over emails, but not a prohibitive issue. Thanks for your help.

at first it was stuck in park and windows wouldn't go up . replaced a fuse so why my car won't change gears?

It will roll down but won't roll up

i replaced the cat and all four o2 sensors and i drove over 100 miles going through the reset cycles and still the computer reading not ready.

i replaced the cat and all four o2 sensors and i drove over 100 miles going through the reset cycles and still the computer reading not ready.

i replaced the cat and all four o2 sensors and i drove over 100 miles going through the reset cycles and still the computer reading not ready.

it will not stay crunk ,we cleaned the maf sensor and it is worse now

while driving car loses power even with foot on gas petal it dont want to accelerate the rpm on dashboard dont even move also it jerks and turns off sometimes. I did a tune up and still runs the same. What could be wrong.

over the past 8 months the car takes spells that it will Not crank. I let the car sit for 7 weeks at first. Then one day it cranked. Then it will not. Have changed plugs, coil pack and cam sensor. Car still in a will not crank mode.