24
questions

I've changed the gadgets and spark plugs. The check engine light is not on, what might be problem?

Whereiscrankshaft sensor locatedon1996nissansentra

Is still doing it, even after losing near 1/4 tank of petrol! Could smell petrol in the beginning, but no longer. Terrible fuel loss!

I have heard that some sort of catalytic converter failure causing particles to be sucked up into the cylinder resulting in scoring and loss of compression. The car just died, no overheating just very low compression on all 4 cylinders. Unable to get it started. Any ideas? Thanks

Power steering fluid leaks everyday

The timing chain is worn so can it effect my power performance
And what could a worn timing chain do to your motor
Nissan sabre 160gxi 95 year model thnks

at first i notice my car was making a ticking noise and i asked my aunt about it and she said i had a valve loose and i also needed an oxygen sensor on the car to. my check engine light kept coming on and the sound kept getting worse so i asked my dad to check it so he finally checked it and i cranked it up for him and let him listen to it and he said it was the oxygen sensor so he was about to go by one and when i cranked it up again it wouldn't turn over, so he bought a oxygen sensor put it on it still wouldn't crank up then he checked the check engine light and it came up to be po303 and then he looked it up and it said my third spark plug misfired so he changed the spark plugs and then the car went dead then he bought a rotor button and the car still wouldn't say nothing i had the battery checked and it was dead so i bought a new one and then the car turned over but wouldn't crank up so i have it and the shop the guy put a new distributive cap on it and the car will crank up all the way but then will cut back off in about 3mins anybody have any options cause the mechanic dont have any please help me. ( Also i have a tiny hole in my high power steering pipe do that have any effected on it not staying started.)

when its idling its good, and when i rev up the engine while stationary, it revs up perfectly, the jerking starts when i start driving, it starts jerking and has no power, i have to give it extra acceleration to get somewhere, it does it in all gears.

it failed smog with high HC at 25mph(57 vs. 62). at 15 mph it'a at max at 92. Changed oil, pvc valve, cap n rotor, plugs, and wires week ago. changed O2 sensor yesterday. 'C' catalyst monitor is blinking in car reader. no codes or cel. In CA, should all the "Readiness Monitor" be available? thank you.

Check engine light stays on. Diagnostic code said speed sensor was bad. I have had two installed and still have a check engine light on. Speedodometer will not work. Diagnostic code still shows speed sensor as being bad. Neither part has been a Nissan part but a generic. Is there any thing else that could be causing this or is the part bad?

emission problem