67
questions

I put my pathfinder in drive and it runs hard? some times it shift at higher speed 35-40mph

Help me out

Replaced starter and it cranked right up turned car off turned key and starter won't stop spinning and wires on battery smoke and the key is not on had to disconnect battery terminal what's my problem everything hooked up right

This happened once before in the winter time, sat for about 12 days then started and now it did it again, Thought it might be ignition related?

I just changed the fuel pump in this car. Right afterwards, I even drove it and it ran fine. It does have an alarm installed. Is it possible that there's some kind of a reset button that needs to be hit since I did have the battery disconnected?

I just replaced the water pump in my 95 pathfinder, the car didnt run at first, come to find out the timing belt was reinstalled slightly off, retimed the belt and it started and ran, it sat for 3 days and now wont start anymore. The engine turns over but wont fire. Already did a compression test 120 to 130 psi across the board, spark to all cylinders and fuel is getting to the fuel rails, so it has all it should need to fire, any ideas please help

I just replaced the water pump in my 95 pathfinder, the car didnt run at first, come to find out the timing belt was reinstalled slightly off, retimed the belt and it started and ran, it sat for 3 days and now wont start anymore. The engine turns over but wont fire. Already did a compression test 120 to 130 psi across the board, spark to all cylinders and fuel is getting to the fuel rails, so it has all it should need to fire but it just wont, im thinking maybe a bad crank position sensor, any ideas please help

Driving home from work, heard water pump go out
Changed it and timing belt...timing was off but it ran
Then i readjusted the belt and still cant see the bottom alignment mark to align it with the crank shaft timing sprocket
how can i find where the old mark is supposed to go? The repair manual pic is too small to read and i only found one internet picture a little helpful..

her engine sounds like she is bogging down and suffocating and she wont move, no gas peddle. It tends to get worse when she is at full operation temperature. also when she does this she revs high then shifts into the gears hard and it struggles going up hill and also loses power and gas pedal. Garage cant figure it out so far they are baffled as well. No codes come up on diagnostics. They have to check it manually now.