1995 Nissan Maxima Questions

All 1995 Nissan Maxima Questions

Ask a Question
i lost my under dash fuse box cover, and i cant dont know which fuse is for.
I got code PO410 and PO503 i believe i read it right 4 short and 10 fast followed by 5 slow and 3 fast. well the car is hesitating to start sometimes and when it warms up sometimes it tends to slight surge in idle as ...
Im attempting to change my car starter where do i find it on the engine
My top hose for the power steering pump leaks when I turn the steering wheel.I bought a new hose and the new one looks diffrent.I need to insall it.How?
were an i get this job done for a real good price?..and also what shop will you subject to have your car fix?
I have a 1995 nissan maxima /v6 3000 i need to repace the waterpmp. I have it tore apart but i cant get the tensioner pidton bsck far enough to install stop pin. can i just remove the tensioner and then put it back or...
how do i know when its my starter or ignition dat went bad?
the transmission is not shifting in higher gears[3 to 4] need to know what the problem is
car won't start must jiggle ignition
Where is the Vapor Canister Vent Valve located? From time to time I smell very strong gas vapors and other repairs I have done have not helped. I want to change this part now, but I don't know where it is located. ...
How to replace the water pump for 1995 maxima 3000?
car wa leaking oil & waater, replaced lower oil pan gasket and systems service pipe. After repairs were done engine light came on and car was running rough. tried to get diganosis and approx cost, but have been told...
Its idling rough and when acelerating its misses out. there is a fuel smell in the car. I just replaced the fuel filter. What else is going on?
we have replaced the battery the alternator everything runs fine and then the battery goes dead. after starting car i take off the positive battery cable and car still runs. help I can't afford massive repairs. car do...
no spark to spark plugs, cam and crank senors have been replaced has injector signal and fuel when cranking but no spark has changed ecu too, checked relayss and fuses lost