I bought this 99 eclipse a week ago and it hase been running fine till now the throttle cable is over heating the guy who sold it to me told me that the fans were not working and the car would over heat but he made the fans direct so they run fine now and my engine doesn't over heat as long as the ac is on but while the ac is running my throttle cable heats up and turns red any solutions

It will not start. When you turn the key, you hear cranking but it just wont start up anymore cheek for a code but im not getting any bad code has a new alternator new battery i cheek the star motor is good i was thinking it is a bad crankshaft sensor but the car cranks so i don't now was wrong and has a new fuel pump to please help me

Have fuel pressure but no spark. Changed crank sensor, cam sensor and coil pack. Still no spark so changed ECU (used one from wrecking yard). Checked all fuses and plug-ins.

P0134 02 sensor

First noticed windows didnt work. Then noticed heater. Also the headlights come on as soon as i turn the key and dont turn off. Please help

Clutch was working fine no problem went into store come back out it won't go into gear? ?

Hello I have a 1999 Mitsubishi Eclipse 2.0 Non Turbo 420a. One day i was driving my car and all of a sudden the car lost power. I stepped and stepped on the throttle but the car wouldn't pick up the speed it had no power in it. The rpm needle would rev but no reaction came from the car. The car then came to a stop and shut down. When i got it home i tried to turn the car on but it just makes a weird screeching grinding noise. Any ideas?

where is the tranny inspection hole?

loud knock noise after shifting from 4th. to 5th. gear

cranks good took out 1 plug cranked over don't see a spark. what should I try next?

i mean in terms of mileage, engine, transmission problems...