2000 Mazda MPV Questions

All 2000 Mazda MPV Questions

Ask a Question
after I drive it for 20-30 minutes it will be very loud and van will cut off of and then when I open up the oil cap is very hot and smoking top of the motor but temperature gauge shows okay
This problem just started. I can feel a misfire when I'm climbing a hill, but not otherwise. The error code I got from autozone is p0303.
It overheated and sprung a leak. I changed stat and not overheating but engine smokes and engine oil light blinks and engine rattles
Okay about 2 months ago I noticed something very strange with my mpv . I was driving then all of a sudden the indicator on the dash was saying my van was not only in drive but also in neutral. then it wouldn't start w...
I have hopes it is just a fuse but I don't have an owners guide so I don't know where to start
car is 1999 mazda mpv auto... when you go to accelerate it feels like the timing is missing and gutless like its struggling to pick up speed but eventually does. No engine light has come on, hubby seems to think maybe...
when driving sometimes the rpm's climb to 5,000 rpm without returning to normal range. If I pull over and let idle for a second in park and then proceed on, the RPM return to normal ranges. Engine light went on had ...
A CD is stuck inside the CD player. It was working fine before. Is there a way to get it out?
Code P0305 (misfire on #5). It has 93,000 miles. I put new sparkplugs and wires and changed ignition coil and Oxygen sensors. Cleaned the EGR and MAF (with MAF cleaner.) Air filter is new. I added injector cleaners m...
I have spark at the green wire at the coil pack but no spark at the crank sensor; which means I don't have spark at the plugs. What is the procedure for checking out this problem? PLease! I just put the engine b...
Engine had an overheat condition,corrected that, engine ran fine . Then it started a slight surging while accelerating.It stalled at a light but started right up. While driving home CE light came on and shift indicato...
my mechanic says it is a crack in the rear exhaust manifold where it joins the catalytic converter. cost $1100 to replace. does this sound right?
car has a po420 in current codes but exibits no running issues at all.
when I am sitting and on my brakes in drive, my whole van shakes and sometimes my van acts like its going to stall while in low idle. what is causing this? anybody?