2002 Lincoln LS Questions

All 2002 Lincoln LS Questions

Ask a Question
tightened clutch disk and pressure plate, but entire assembly moves around on flywheel. Is this normal or did i miss something?
I accelerate and it seem like it don't wanna go due I need my solenoid clean are exhaust system by the converters clean can u help me tire being broke with this vehicle
Fuses were checked and found to be okay.
I Just had the fuel filter changed and the next night after having it changed the number 17 fuel pump motor fuse?car ran good before this
it just turns over i usually have to do it a few times before it starts, but once it does it will start all day with out fail, the next morning saME PROBLEM, from breife look on web ive seen IAC valve, fuel relay, and...
I recently had to have my Lincoln LS 2002 serviced because every time I hit the gas, it would get really loud like a truck. The check engine light is usually always on, but it started blinking after driving maybe 5 mi...
My Lincoln LS 2002 started saying ABS Check Traction Control today but after I turned the car off and back on later it doesn't say it anymore. This just happened today but need to know how much it would cost to test a...
piller filling the map holder on the door and soaking the carpet i do have a sun roof
fumes only come up when car is still.Is there a common leak area that can be tightened up.I can hear no exhaust leak at all. Could it be in front of the cars? Thanks, Steve
recently started having this problem white smoke coming out exhaust
Had white smoke coming from under the hood. I did a tune up and found oil where the spark plugs are. I know this signifies and blown head gasket however. I DONT HAVE water nor coolant in the oil on the dip stick. No o...
Car cranks on start for about 3-4 seconds before starting, once in a blue moon a popping noise is heard from the engine at start followed by a bad smell in the cabin if a/c is on. All 8 coils (COP) have been replaced...
the sound seems to be coming from under my feet in the drivers seat. It is a constant humm/whine, with no change if idling or accelerating.
When you start the car the air bag light blinks and then it stays on
No diagnostic codes (DATC); repaced DCCV today, no difference. Followed thread to get to the point I ma now, could use some help. Thx, WJL