43
questions

The plugs, dual coils and fuel filter by the engine have been changed by Firestone. Still runs BAD! The exhaust smells funny, and has no power. The idle is really rough. I thought the head gasket was bad, but no oil in the radiator fluid, and no water in the engine oil. #frustrated

I did a compression check got a reading of 145 on cyl #1. (check ENG code Cyl#1 misfire). we replace injector,omed tested plug wire /coil pack check good within spec.range as per factory repair manual.(verified 12 volts going to coil pack's /r+r plugs/r+r fuel filter and fuel in tank also oil and filter changed,All vacume lines check good no cracks or leaks.Vacume tested EGR valve working like it is supposed to (engine stalls out)as per repair manual.I have pulled only the top part of the intake manifold and throttle body and intake hose from air cleaner to accsess injectors.I did not remove the part of the intake that is attached to the the block.Help i am stumpped.car sat for about 4.5 years, R&R clutch ran great for about three weeks then this problem.Thank you for any advice you may be able to give me.

car was driven to the mechanic, he did cat converter work, now says the car is stuck in 4WD and he can't "muscle" it out in to regular drive and that I can't drive it till that is fixed. Any suggestions? and can I drive it home? (less than 1 mile)

THERES A LATCH ON THE INSIDE OF DOOR (CHILD PROOF) THAT WHEN YOU PUT THE PROOF ON IT DOESNT OPEN FROM THE IN SIDE OR OUT SIDE OF IT

The camshaft sensor is right on the fire wall is there anyway I can change it with out pulling the motor

Where is the n/s sw on 97 sportage

took the car to mechanic then to dealer found other problems but didn't fix the one that started them what to do please help! 1000 dollars down the road still having same issues

Top cable comes from pedal. Where does the bottom cable attach to. It is loose so it wont return to idle. Both springs are in tact and not broken and the assembly seems ok. If I knew where the bottom cable is attached, I might be able to see what is causing it to stick and not return to idle.

Check engine light came on, but car not overheating. Testing shows i need transmission control system. Is this a recall issue? P0700, P0711

sometimes not all the time

car overheats

the car overheats

had 4-codes-oxygen sensor mass air sensor egr system evaporative purge valve i have replace all this itstill fail