Close

1999 GMC Yukon Questions

Get answers to questions about your 1999 GMC Yukon at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
92
questions

Freon level is good, clutch is operational. But do not have any service lights on.

I have gone about 240 miles and it is reading between 1/2 and 3/4 tank I know that's not correct. Then sometimes it will start to work. What would cause this?

Out the back vent

3 weeks ago I turned my AC on, it blew for about 3 mins and stopped. No blower at all, nothing. I stopped at my destination and when I started the truck again, all was normal again. Now two days ago the same thing happened except it will not come on again. Gauges are fine, fuse is good (replaced), fairly new compressor (14-16 mos old). It seems electrical in nature and some of the radio buttons are going out over time. Any thoughts?

A week ago car showed code P0171. Shop cleaned throttle body, found no vacuum leaks, and cleared code. One week later engine light came on, code was P0741. Shop diagnosed as the torque converter solenoid was stuck in the "on" position, so needs replacing requiring opening up trans to access.

My 99 Yukon has brand new tranny and motor. Was driving and it suddenly cut out like it was going to die and running rough. Got it home and it started misfiring and making ping and pang sounds. Checked fuel pressure wasn't fuel pump. Changed all plugs, wires, and replaced fuel filter. Checked distributor and it was good. It seems to be getting fire. What could be the problem? I was told since the check engine light isn't on I couldn't hook it up to a diagnostic computer to run codes. Please help!

Need to replace the module it keeps blowing fuses and will not shift in or out of 4 wheel drive

Just picked up the vehicle it has new cap rotor plugs wires checked fuel pressure is good at 60lbs and holds 45-50lbs when left to sit for an hour any other ideas?


automatic shifter into any drive positiom it grinds. the same noise a manual does notusing a clutch

its not making any type of noise it had not been driven for a while once before I took the battery out to reset and it worked normal I changed them and unhooked the battery to reset and it didn't work this time

my 1999 yukon sle after running the vehicle about an hour and park it when i go to restart it it just cranks and will not fire. let it sit a day and try it it will start. i have changed all plugs cap and rotor fuel filter exhaust (catalitic convertor) and i am getting fuel and spark . i also changed the 02 sensors as well . vehicle sometimes will go for a few days sometimes before it starts doing this again . it seems to have a mind of its own i am at a loss

Engine starts and idles fine, but stumbles when I press on gas, and won't cruise past 100 kph

It was a very cold morning, I warmed up my truck. About 1-1/2 miles from the house oil leaked out onto manifold on the drivers side, smoking like crazy. By the time I could pull over, it just died. While sitting there oil puddled under my truck. I checked the dip stick, completely dry of oil. I really need a mechanic!
Thanks for any help or advice, kymberly

It leaks slowly when the engines in run.

Had a leak that looked like it was coming from the bottom left(passenger)side of the w/p. Replaced, and we still have the leak. Replaced w/p,gaskets, and coolant.
Thanks!