1999 GMC Yukon Questions

All 1999 GMC Yukon Questions

Ask a Question
Had a leak that looked like it was coming from the bottom left(passenger)side of the w/p. Replaced, and we still have the leak. Replaced w/p,gaskets, and coolant. Thanks!
Have 99 Yukon 2wd 5.7 135,000 since new and most of time engine will not slow until I apply brakes. Idles correct, no service light or code. Years ago dealership replaced TPS and worked a couple days and returned. Thi...
Have 238,000 miles on my Yukon. Have been told 300,000 miles is nothing for this vehicle. Wondering what it would cost to put a new enngine in it rather than buying another vehicle!
My yukon is getting a code that says random multiple misfire how do you fix this? I had the spark plugs changed,replaced the distributor and then replaced the fuel pump and now it is getting the random code but it wa...
what are the signs of rear end replacement
started rough idling out of the blue one morning.Fires right up and drives but rough. P0306 code.Engine light flashes when driving but is steady when idling. Changed spark plug from cyl 6 to 4. Still reads misfire on ...
I'm guessing it's some type of electrical failure..how much for a diagnosis, and or replacement of damaged electrical wiring...not sure whats wrong
Someone tried to break in my truck and yanked the gear shift down into neutral and broke it off can it be replaced or do i need to replace the whole column?
Had a check engine light come on this weekend both times were when I was accelerating up a steep mountain pass. The light would come on and then flash throughout acceleration. Eventually just staying on. The code said...
started in the 32 degree weather we have nere in VA.
installed vortex 5.7 engine ran good on highway for 15 minutes then it went dead I replaced the battery towed it home now it misfires trying to set the timing continues to misfire any suggestions
MY DRL DO NOT WORK FUSEES ARE GOOD AND I CAN NOT FIND A RELAY FOR IT THE OWNERS BOOK SHOWS FUSES ONLY NO RELAY COULD IT BE THE EMERGENCY BRAKE SWITCH IF YOU HAVE ANY IDEA WHAT IT COULD BE PLEASE LET ME KNOW
my daytime running lights do not work fuses are good what could be the prolem
The timing chain broke, I replaced it, aligned the marks on the crank & cam shafts, brought #1 plug up, but I still dont have any fire. What's wrong? Am I missing a step?
Our 99 Yukon will blow cold air out of the rear but not in the front. Has a new control unit in dash, compressor works fine. The cold air is not coming through the vents in the front. Would like to know what proble...