35
questions

Fight if I'm driving it will not let me shift into 4th gear it shaved down into low gear

No need for detail.

I put my old brake booster back in and I even replaced the brake light sencer that hooks on to the brake bar what ever I try nothing is working.

I'm having trouble with my brake lights not working since I replaced the booster and the brake light switch. Any suggestions.

I changed my brake booster with one out of a Chevy truck and I couldn't get the shifter to come out of park unless I started the motor then turned it off just so the engine died then the shifter would move, but I had no brake lights either. I put the old booster back in to see if that was the issue but it still malfunctioned . I then replaced the brake light switch ,still no help. Can you point me in the right direction.

I have a very high idle speed, the tach. and speedo. appear to be dead (even after instrument cluster being replaced), i have to manually shift the trans due to it not shifting on its own and also not engaging into over drive. With the key in the "on" position, motor not running, the instrument cluster indicates what gear the shifter is in (i.e. 1st thru drive) but with the motor running it no longer indicates the gear. I have no idea what to look for any longer.

I will be driving and it just dies on me, we have noticed the fuel pump relay switch gets very hot so we replace it and it starts again. I have had fuel pump, ignition switch, distributor cap & wires all replaced. I have had in the shop several times and they keep replacing things and have traced the wires. They are lost and cannot figure it out. Any suggestions?

after i drive it for 15 minutes and is hard to star i used scanner and has no codes

<forfe] driving down the highway is not the same as before,i have to press down the pedal to try to maintain some speed.


1995 Chevy Yukon, 5.7, 4WD. Stalls, lacks power. Oxygen sensor code.

Intermittent stalling at stop lights, lacks power on acceleration. Get service engine code for O2 sensor after driving.

Replaced O2 sensor, fuel filter, plugs, wires, distributor cap and rotor,TBI sprays look good at idle and higher rpm.

Some times will not start on 1st attempt. The TBI does spray fuel during this and the fuel pump is working, but engine does not start. Will start on second attempt. Any suggestions?





Problem just started. Checked fuse...it's ok.

i need to know what kind of oil my 1995 gmc yukon take 5w?

IT DOESNT HAPPEN ALL THE TIME HOWEVER WHEN THE SERVICE ENGINE LIGHT COMES ON THE ENGINE STARTS SURGING RPMS RANGE FROM 15OO TO 2000 RPMS. WHEN THIS HAPPENS THE TRANSMISSION SHIFTS VERY HARD. YOU STOP TRAVEL AND KILL THE ENGINE THEN START THE ENGINE AGAIN THE PROBLEM STOPS FOR A WHILE AND THEN PROCEEDS TO DO THE SAME THING. EGR, TPS, ALTERNATOR, BATTERY, THROTTLE BODY HAVE BEEN CHANGED. ALSO THE FUEL PUMP AND A TUNE UP HAVE ALSO BEEN DONE (PLUGS, PLUG WIRES, DISTRIBUTOR CAP, ROTOR, etc...)SCRATCHING MY HEAD HAVE NOT BEEN ABLE TO PULL CODES.