42
questions

Geo Prizm with 122000 miles. Alternator was faulty making loud noise and a burning plastic smell. Replaced with new DENSO alternator and later 3 OEM Toyota belts. Loud noise and smell went away. Though, squeaking noise was really awful with the older aftermarket belts. It's much better now with new belts, but still a bit of squeaking with start-up, and worse when AC is on. After a good drive the noise disappeared. I just don't want this alternator to go bad prematurely. AC blows nice and cold and have not noticed any issues. What is still causing minor squeaking and how should I proceed?

Aftee i pull ovee and let it sit it will start right up. What can it be? Thermostat gage says its not hot.

When I start it at a cold start it runs just fine, I drive a few miles and then either I press the gas and all I get is a raving engine and no motion of force, or it does move, practically having a violent shaking seizure and then no motion of force just engine rev. No warning lights show, and it only does this when it's hot or already ran once about an hour or so prior.
Please help me.

It is leaking bad when engine turns off down by the pump or seals. When i take the radiator cover off It stops. I dont know exactly which one. I am troubleshooting small to big. Air is cold, Heat is fine, Oil is clear, belts are fine. I am at a lost. The Haynes book is not good on pictures either. Anyone out there to help a lady. Thanks

Wires stripped on master harness

My starter wont disengage. Unhooked battery to stop engine from running. What next?

Power steering pump very noisy on cold day startup. System itself is slightly noisy under normal operation though the steering operation seems fine. Our excellent mechanic has replaced entire system including rack, pump, and hoses. Still get noise on cold startup. Seems like there is a slow deterioration of the pump over time.

At wits end. Do the 1997 Prizm 1.6 have a chronic problem? (The issue with the pump started last year when a mechanic replaced one and then another and then another and finally also repaired a leak in a hose.)

The car has been very well maintained and is otherwise in excellent shape.

Messing with the steering wheel helped and it started right away, a brand new battery and all the lights go on and radio just won't start, any help???