Since it came out of the shop and the cover wasn't put back on the warning says 6 percent on oil even though it was just changed.

Where is my fuel pump located???

My car will start up and idle but it idles at 1500-2000rpm. When you give it gas it will cut out if you give it gas to quick. If you slowly accelerate it will rap out just fine I've replaced air idle control, coolant sensor, and tps. Also car has new plugs, wires, and distributor cap. I'm not so much worried about the high idle but the cutting out and hesitation when trying to accelerate

1991 Geo Prizm stopped running while driving. No start after that. Getting fuel past the fuel filter. Rotor and cap less than a year old. Removed cap and rotor turns when trying to start so I am guessing it's not a timing belt issue. Car has 61000 miles. Wanted to know if anyone can tell me if I have to replace the whole distributor or is the ignition coil replaceable.

Happens every time it gets below 1/2 tank.

when locked in 4 wheel drive will not engage. Why not?

Geo Prizm with 122000 miles. Alternator was faulty making loud noise and a burning plastic smell. Replaced with new DENSO alternator and later 3 OEM Toyota belts. Loud noise and smell went away. Though, squeaking noise was really awful with the older aftermarket belts. It's much better now with new belts, but still a bit of squeaking with start-up, and worse when AC is on. After a good drive the noise disappeared. I just don't want this alternator to go bad prematurely. AC blows nice and cold and have not noticed any issues. What is still causing minor squeaking and how should I proceed?

I have 95 Geo Prizm 1.6. It has high mileage. It was running good until this morning when i stopped to pick up a rock on the road. When i press the gas it stalled. It crack but won't turn run. I checked the fuel pump and fuel filter and they work good. Getting gas pass the filter. What do you think it is? Injectors or timing belt. Thank you, Thomas

Why does the oil light come on and stays on?

my car will crank up and run perfectly fine and it will drive for a lil while, when the temp gauge gets about halfway, and I come to a stop light the engine will turn off. the "check engine" light is on also as well. when it shut off, I let it sit for about 30min.-1hour and it will crank back up and run but it will began to overheat and when I come to a stop sign or a red light the engine will turn off again , I'm not sure whats wrong with my vehicle, can anybody help me , the battery is good , the alternator is fine , I just had my power steering pump replaced , when it blew the was oil all over the place, but eventually was burned off , the serpentine belt is good. can somebody please help me.

white smoke and strong fuel smell coming from tail pipe

I looked under car for loose suspension parts but see nothing wrong. This just started happening at slow speeds. What is causing the problem? Thanks

Was running rough, distributor lobes were in bad shape, replace it with a used spare distributor in good shape
After this, eng. start every time but stall immediately

changing ignition s/w need to remove wheel and turn signal and airbag

Geo storm 91 every time clutch pushed in car shuts off. you can crank it and idle all day log runs great, but push that clutch in off it goes, has dealers stumped. No vac leaks timing spot on.

Stains on the ground or no smoke coming out the exhaust. Could the pic system have something to do with it.any suggestion would be apriciated

when u start car or drive u can hear an engine knock,is that a rod bearing going out or is it worth fixing?

Parking brake location?

Aftee i pull ovee and let it sit it will start right up. What can it be? Thermostat gage says its not hot.

My 95 prizm idle bounces up and down. I changed the throttle position sensor and it still does it. What am i doing wrong or missing to fix this problem?

Starter now just clicks. Battery is fully charged. Help! Thanks!

The headlights stopped working however the fog lights still work as well as the passing lights. The high beams dont work and the low beams do not work.

I have dash lights but they dim until i let go off key. When it was running the inflate light came on and stayed on.

No auto parts store can get me a clutch slave cylinder for a 1997 geo tracker. Is the part compatible with one from a 1998 chevy tracker?? And where is it located?

Dash lowes din till you cant see them as soon as i release the key lights come back on but wont do nothing

Idk even where to start with this.. Not sure what I even need to look at! When I turn the key it starts to turn over, & then starts squealing but it won't start