Geo Questions

All Geo Questions

Ask a Question
After starting and key is returned to run position engine for 30 sec,and quits. It seems like there is a circuit in the run position missing.
Has new tension pully new plugs and wires new head new starter an new motor gaskets
no gas peddle acts like its running out of gas but ...is idles....push on gas peddle and nothing
When I shift it stays in reverse. N.d.d2 and L. Why would it do that?
when hit button nothing no water goes up to window no sound heard
I killed my battery and thought it was bad so I put in a new battery. This battery was too large for the car and I put it in backwards which blew the 100 amp fuse. However, the car will still not start. There is not s...
Wires stripped on master harness
I have a 1995 Geo Prizm 1.6. Yesterday while running some errands the car chugged and acted like it was running out of gas then it died and would not start again. Today I changed the PCV Valve and got it to start. It ...
to the point that I have no pedal. Its not the emergency brakes, cause I checked, its definately the front brakes. what could be causing this?
It rusted to pieces along with the bar in front of the tank plus so r the shock towers what do i do to fix all this?
Inside the car my temperature gage seems to go from cool to middle of hot and stay in middle of gage. I see no water in thing in front. How can I reset codes. To figure out what's wrong.
The car turns over and runs great as long as I feed it starter fluid. I can hear the fuel pump priming so I disconnected the fuel line from the fuel rail and watched a good flow of fuel coming out while I was cranking...
My head gasket blow and I got it fix but ever since it turns off at stops I got it idled high but that just made it race when I stop or I don't have to have my foot on the gas for it to drive so I got it idled back d...
acode po705 came up my friend changed the transmission filter,fluid,screenand the oil oil filter
Headlights left on all night. Load test on battery shows its fine. No power at all even when attempting to jump start.
when the key is turned on the headlights don't go on as they always did in the past
Just wondering as I'm trying to get this car inspected and was told the universal boot is bad and needs replaced to pass inspection.