57
questions

Where is my fuel pump located???

My car will start up and idle but it idles at 1500-2000rpm. When you give it gas it will cut out if you give it gas to quick. If you slowly accelerate it will rap out just fine I've replaced air idle control, coolant sensor, and tps. Also car has new plugs, wires, and distributor cap. I'm not so much worried about the high idle but the cutting out and hesitation when trying to accelerate

I have 95 Geo Prizm 1.6. It has high mileage. It was running good until this morning when i stopped to pick up a rock on the road. When i press the gas it stalled. It crack but won't turn run. I checked the fuel pump and fuel filter and they work good. Getting gas pass the filter. What do you think it is? Injectors or timing belt. Thank you, Thomas









My 95 prizm idle bounces up and down. I changed the throttle position sensor and it still does it. What am i doing wrong or missing to fix this problem?

It would run decent then bad now it has over heated & I think a hose is busted, what do I do? I can't really afford to put it in the shop right now!

I was driving down the highway about 45mph and suddenly nothing it wouldnt move. I had lossof power and then nothing.

My car has been running fine then out of no where my car loses power. The brakes get hard and the car seems like it goes into neutral. I'll shut the car off and let it cool down, even though it never overheats, and then the car will run like normal. This is the second time it's happened this week. I checked all the fluids and nothing is low.

I have a 1995 Geo Prizm 1.6. Yesterday while running some errands the car chugged and acted like it was running out of gas then it died and would not start again. Today I changed the PCV Valve and got it to start. It idles just fine but when I try to give it gas it bogs down and eventually dies. After this happens, when I try to start it, it takes a while but will start and idle just fine. If I feather the gas I can tach it out, but if I try to lets say take off normally, it will bog down and idle rough before shutting down alltogether. I've heard the TPS could be at fault, or the fuel filter, or the fuel pump. I've also been told that the ignition coil could be my problem. I just need some more input, any would be greatly appreciated. Thank you

When the car is cold it starts fine, but when the engine warms it takes a bit to start. There is no check engine light while the car is idling.

We were installing the ignition control module. When putting the ignition coil back on a brown wire broke loose and we don't know where it broke loose from. The one end (with the round metal piece) was on the ignition coil and the other is just broken.
Would you be able to tell us where the other end goes?

Starts and runs fine but when you drive 1/2 block it dies and will usually restart again in neutral and park but when placed back in gear it dies again.we replaced the fuel pump and filter.

Put a brand new fuel pump but no power going to the pump

Changed passenger front tire an then this started