95
questions

it doesnt happen every time i drive it put most of the time. its a 2.3l manual transmission with 110,000 miles

it doesnt happen every time i drive it put most of the time. its a 2.3l manual transmission with 110,000 miles

it doesnt happen every time i drive it put most of the time. its a 2.3l manual transmission with 110,000 miles

My dash not light up when I put my ranger into four wheel drive. I cant hear anything thing if it goes in. When I have the hubs lock in and on black top I dont feel any grabing of the tires?

Is there something wrong with the four wheel drive or is there something wrong with the dash and push button lighing up?

When I drive local it doesnt burn oil but when i drive long miles, it burns about a quarter of a quart. So what is causing it to burn oil on long trips? You can see blue smoke and smell oil buring

93 4.0L 4x4 a/t

i rplaced the fuel pump coil pluges wires and fuel pressure regulator valve mass aif flow sensior throtle body postion sensior idle contol valve fuel pump relay and it has a hard time to start but when i get it started it idles high and runs slugeis but i can drive it for like ten mins and it runs great but when i shut it off ther motor is hot and it want start back for like may one or two houers and also i smell gas really bad but i have no leaks of any kind and it smells like its over loading with fuel when it quits running

Its a 1993 Ford Ranger and I just don't want to mess anything up, I am replacing calipers and brake pads and need to know the best way to drain and replace brake fluid and afterwards bleed the system. I was told to go from the front driver side around the truck till you get to the back driver side to bleed the system so if that's correct I just need to know how to drain and replace the brake fluid thanks

I even took off the brake fluid cap under the hood and used a clamp to push the caliper back in. still could not get it and every other vehicle i have ever had thats exactly what you do

I have a skipping in my truck. I have changed spark plugs and the gas filter. It has been sitting up for over 1 year before I bought it. What else could it be ?

replaced slave cyl for clutch, bench bled master. on reinstall of shifter, asst. somehow managed to get the internal trans mechanism off / uncentered at linkage point where shifter pegs into. pulled shifter off, flipped internal parts back to normal, ran fine. now trans is acting like its dragging or otherwise not right. no idea how it could have been damaged or misaligned inside.

i have removed 3 bolts but the cowl looks like made in one piece

I did a compression test and got two low readings one on each side and directly opposite of each other. what is the cause?

sometimes it runs good and somrtimes it will skip an then start backfiring thu exhaust has codes 111,222,223,224 installed both coils, all 8 plugs an wires, crankshaft position sensor, catalytic converter please help if you can

the bracket in front of the rear tire that connects the leaf springs to frame has rusted and disconnected from the frame. how much will a shop charge me to replace this bracket?