Close

1994 Ford Probe Questions

Get answers to questions about your 1994 Ford Probe at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
22
questions

OK so it started when we get home one day an everything fine she handles like normal. then she wont start. i look im not getting a spark. so i find out its the coil pack replace that then then i cant get it aligned then after a few weeks (only a few hours a weekend)she just stops turning over and i just get the click from the starter anyone have any ideas? many thanks if you do!

Think it might be stearing linkage

What adhesive is recommend

It ice here tires are fighting independently front wheel Drive scary

The car is dead but lights, radio, etc. work. When I turn the key there is no sound at all.Any ideas what it could be be?Checked the starter and that seems fine, externally. I know it's probably a coincidence but the only maintenance I did to the car was to replace a head light the day prior to not starting. Any help would be appreciated. Thanks

happens every time i drive my car .the engine doesnt seem to be affected.

What could be wrong? I installed a new battery and it is acting like there is no battery installed. No horn no spark no click no lights- nothing!

V6 Auto runs and drives good , just wont shift

ROUGH IDLE AND LOSS OF POWER. ROUGH ACCELERATION AND STALLS

No power, rough idle, replaced plugs wires, plugs, distributor .

how do i locate this part?

it eventually stops making that noise when i start going

i put my probe in the shop for a motor .they replaced my motor with a mazda motor .will it work in my probe since it is a mazdmotor

PULLED TIMING COVERS TO SEE IF IT JUMPED TIME,ALL MARKS LINEUP BUT DISTRIBUTOR IS WAY OFF,SPARK IS WEAK AND ORANGE,I'VE REPLACED THE COIL-INTERNAL IN DISTRIBUTOR-STILL WONT START-SPARK IS STILL WEAK AND DONT UNDERSTAND WHY DISTRIBUTOR IS SO FAR OFF WHEN ALL OTHER MARKS ALIGN.

my probe only goes in reverse and wondering if i need a whole new transmission