122
questions

This only happens when i accelerate.what could this possibly be??

Driving in 2 wheel drive on a sandy dirt road at 45mph, hit a narrow, deep rut. Wrench light came on. That was 40K miles ago & no noticeable degradation of performance. Ford dealer says solution is to replace the transmission...?! I'd like to trade the car but the value goes down with the power train light on! Any suggestions?

Will they look at transmission, spark plugs, small items? I'm a widow, and no nothing about a car. Just want to be able to inquire questions that need to be asked, but don't want to be charged for things that are working properly. I travel alone a lot and want the safety of my vehicle.

Started when I bought the vehicle and would put the defroster on. Now blows cold air like something is sticking and not wanting to provide warm air. How to determine problem and how to fix without expensive repair. I have only
put 2000 miles on this vehicle since I bought it. Now has
61,000 miles.

I have a ford explorer 2006 and the battery light turn on frequently, already check the voltage of the battery and the alternator has the required voltages.

THROUGH THE FRONT AND SIDE VENTS, COULD THIS PROBLEM BE A BLEND DOOR ACCUATOR OR A VACUME OR VENT DOOR ACCUATOR? IVE BEEN TOLD THE BLEND DOOR ACCUATOR IS FOR THE HEATER?

front vents?

Checked battery and connections all good, checked starter, starter good, checked fuses all ok just don't know what else to check, not showing any trouble codes, this is the first time its happened

I keep hearing different things and am not sure which is right

Shop says my fluctuating heater and occasional loss of power are due to head gasket problem. $2600 job. Is this plausible?

then shut off and then I turn on again and it seems ok - I put in a new battery but I dont' know if it is the alternator or what- I don't want to waste money on the alternator if it is something else - can it be the voltage switch and is that expensive - this is driving me crazy!!

brakes are good, just had them checked, any ideas? Happens after the car starts moving. The abs is on all the time.

2006 Explorer sounds like a Jet Engine lately. Rev's real high more and more. Seems like a fan or something but I can't pinpoint it.
Temp gauge spikes sometimes not very often but sometimes. Also I have heard what seems to be fluid in my dashboard sloshing around.

Any thoughts would be appreciated.

Peter B

Dealer says they can't find anything wrong with it.

what tool do i need

My ABS, WRENCH/TOOL LIGHT ALONG WITH SLIPPERY LIGHTS COME ON AT THE SAME TIME. Been happening for about 3 weeks. I notice if I get at or above 60mi the lights come on. What could be causing my Dash to light up like this?

Already change a rear sensor.