122
questions

I understand there are three pieces to repairing P0402 code I want to know where to locate them on the motor.

I understand there are three pieces to repairing this code I want to know where to locate them.

On the setting knob for Max ac /face/feet/ defrost,I will turn on to max and it comes out of defrost vents at the dashboard. The feet/face setting will blow air by feet but not main face vents. It is blowing cold, can't figure it out. Please help

This tranny was professionally rebuilt. After reinstalling it, I keep getting the wrench light and code p0715. Shifts great except when going from 3rd to 4th (then light come on). Wrench light resets everytime the car is turned off, does not come on during idle, when driving it only comes on between 3rd/4th gears and stays on til vehicle is turned off. I can clear the p0715 but will come back as wrench light comes on. I have put 2 new sensors in, new fluid, new pcm in trany..


Had a diagnostic check and was told it was the left front wheel bearing.
Could it be the computer needs resetting?

Driving home steering wheel got stripped. At one point the wheel turned around 360 degrees or more and horn got stuck on for about 1 mile. Now the we changed the steering wheel for same year and model none of the steering wheel gadgets, IE horn, radio controls, cruise controls, air bag or a/c controls work. Could the wiring harness been disconnected or shorted on the other end? Your advice would be greatly appreciated.

I took my truck to the Mech's, because i had a prior issue with the front right tire after a simple break job. They repaired by replacing some bearing and the abs sensor. after a couple of months, when i would turn left, it would make like a rubbing noise, so i took it in, and a bad bearing on the right side, this was also replaced. but when i was driving it back it, i would hit the gas but it wouldn't want to move and the it would go. That is when the abs/trac control/ and wrench indicator lights appeared. I took it back to the mechanics, they said that they couldnt find the problem, because the computer codes said it was good to go. but it wasn't. So they pulled some fuse for the abs/trac. and the truck ran normal, but still the lights are on. They said it may be the abs computer or module, because it controls both the abs and trac control. would that be correct? Is there anyway to fix this problem. I really would like my truck back to normal. Also what is the name of that part?

Both seat motors have failed this seems to be a common problem is there any type of fix (IE a newer motor will not fail again)

SRS indicator light does not light up when truck is started. Chime warning sounds 5 times in a series of 5 times every 20 seconds every 30 mins. Need to replace bulb need to know what size to buy.

Is this true? It was rebuilt 15 months ago (out of warranty of repair now). I don't want to rebuild it again if it really just needs a new solenoid pack, but the repair shop said it for sure needs a rebuild after driving it and diagnosis.