18
questions

Tested battery -ok
. atenator -ok however seem like regulator not working but were is it. Inside alt? Do I have to replace whole alternator, rather should I?

And if,,, how about tention pulley or serpentine belt....27k miles 4yrsold

I have a 2012 escape with 18,500 miles on it bought it new,about a month ago it started a low winding noise when I would go about 30 miles a hour now the noise is getting louder and louder,it runs great shifts fine,but sometimes it seems like it gets stuck when you go from 20 to 30 miles a hour. we have rotated the tires and we even tried changing tires with a friends escape and still the noise is there? Any ideas?

When the car is stopped, there is a noise in the engine. I had the pulley checked out and they did a repair, but this is either a new noise or the same noise has come back. It happens every time I stop and the car is idling.

I purchased a used 2012 Ford Escape, as is of course, less than a week ago.
Are the above issues a costly fix and what could possibly be the reason for the issue(s)?
Thanks In Advance

The message saying check brake system came on my dash whik going 65 on the highway. Now every time I start my at and start driving my rpms will go up and will never let e go above 20 it feels lie the brake is rig pressed while the gas is being pressed and will continue to slow down if I continue to press the gas eventually the messagbillsho back up on my dash an the car will drive normally what could be wrong?

error codes p0463

Hello, thanks for taking time to read this. My wife has a 2012 ford escape and always been greatly maintained. It was 47 degrees out today and she was driving into work. 10 mins later car died in the middle of driving. Battery and oil light went on. Checked the oio and battery and it was fine. Could have something went wrong? She just fired the car up and drove. Could it be that the car didnt warm up properly? Thanks for the help. Any would be great. Thank you

I had my ford escape 2012 engine washed,what caused the throttle to have problem is it because of the engine wash or other problems ?

Ford dealer in Bahrain use 10w30 oil instead of 5w20 in my escape 2.5 L4 2012. Due to this, i have tappet sound or VCT sound when the engine is cold after 12 hours for 2 minutes . they said , it is a normal sound and the oil needs time to circulate. therefore , I need opinion in this matter of issue . the sound appear after first oil change and the sound is louder during this winter .

Second time for this issue. Acts like battery is dead. Opened hood and after short period, vehicle started. Acted like there was an open electrical thermostat that had opened after and opening hood, it cooled and closed the circuitry allowing vehicle to start. Any suggestions as to what may be wrong?

how do you remove the inner door panel on a 2012 ford escape?