Close

2006 Dodge Charger Questions

Get answers to questions about your 2006 Dodge Charger at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
149
questions

It does not matter what type of gas I put in or if I put more in after it clicks off. Sometimes it does not start right away and takes several tries, sometimes it starts right up and then is still jerky. After about 5 minutes or so, it drives normally with no problems.

rpm goes high and wont shift to second gear just had transmission serviced last week and was told it looked great. the battery light on dash came on right before the car dead

I am trying to play my music from my phone through my car radio

While driving 25mph or greater my engine will turn off and then restart. When going less then that my engine will turn off completely. There is no indication of rough idling or engine malfunction, I believe it is an electrical issue. I recently had my fuel tank replaced hoping to get rid of this problem. The engine runs beautifully but this issue occurs after driving around for a while and my engine is hot. I think its something to do with the placement of the fuse box in my engine

Replaced thermostat and gasket

Revs up n park but not n gear

code PO113 intake air temperature circuit high input is showing as my car's problem and i dont know what the sensor looks like. The car refuse to start when its the temperature is hot

The car sat for two before I replaced the engine. The car started right up and runs smooth and drives smooth. Thing is can't get the cel to clear.

I was told it needed to replaced with reman engine. I can't find anything which states that intake isn't transferable.

It's being repaired and they have it it fur two days.

my husband left the lights on at work had to get a jump off. the next morning had to get another jump off. Went to o'reilly's the battery tested good. no check engine or esp indicators ever came on. Got up this morning and had to get another jump off. What is the problem?