143
questions

Ocasionally after I come to a stop (sign or light) the trans wont shift out of first gear. I have to pull over shut car off and restart, then it will work right again. It is not throwing a service light and doesn't happen all the time. Had oil and filter changed with no change in outcome. Any suggestions?

Stop and go traffic I will slow to a stop and it locks in first gear. Have to put in park, shut it off, restart then it will act properly. New fluid and filter changes nothing. 113K miles first problem. Doesnt happen all the time but at the most in appropiate ones, like on the freeway.

AAA Autocare replaced my transmission in my Dodge Charger in August 2014. Recently my starter went out and I took it back to AAA Autocare, the technician says that the transmission was put in wrong or maybe not aligned, could it be the reason my flywheel is damage?

As I hit the brakes sometimes my oil pressure light comes on or even if I turn the wheel all the way it does it as well.

seems ok on connections, all been ok ,maybe in switch or ignition?

It does not matter what type of gas I put in or if I put more in after it clicks off. Sometimes it does not start right away and takes several tries, sometimes it starts right up and then is still jerky. After about 5 minutes or so, it drives normally with no problems.

rpm goes high and wont shift to second gear just had transmission serviced last week and was told it looked great. the battery light on dash came on right before the car dead

I am trying to play my music from my phone through my car radio

While driving 25mph or greater my engine will turn off and then restart. When going less then that my engine will turn off completely. There is no indication of rough idling or engine malfunction, I believe it is an electrical issue. I recently had my fuel tank replaced hoping to get rid of this problem. The engine runs beautifully but this issue occurs after driving around for a while and my engine is hot. I think its something to do with the placement of the fuse box in my engine