Close

2006 Dodge Charger Questions

Get answers to questions about your 2006 Dodge Charger at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
149
questions

It make a noise as if somethings loose. I put three quarts of oil in my saturday. It was working fine til the end of the day. It was makjng more noise. Help me please. I can't afford another car nor afford for new motor.

My 2006 dodge charger was fine until one day i went to the grocery store and came out, it wouldn't crank . had it towed home the next day tried to crank it it made a weird rattling noise,one mechanic told me it needed spark plugs so i had them replaced it stopped rattling and crunk but now it has blue or whit smoke coming from the tailpipe(lots of it) it never ran hot nor was the oil low it has a little over 170,000 miles on it.motor is not knocking.please help

i have a 2006 dodge charger and about a week ago on my way home from work in matter of seconds my car turns off but when i try to start car back on it turns back on and able to drive but today my car started making a very loud knocking noise

There is a rattling noise when I hit bumps at low and high speeds my steering is not effected there is no swaying at highway speeds and when I hit bumps I don't bottom out and it doesn't hit hard either I've been told by one person it sounds like a sway bar link or bushing and told by another it's sounds like struts

Ocasionally after I come to a stop (sign or light) the trans wont shift out of first gear. I have to pull over shut car off and restart, then it will work right again. It is not throwing a service light and doesn't happen all the time. Had oil and filter changed with no change in outcome. Any suggestions?

Stop and go traffic I will slow to a stop and it locks in first gear. Have to put in park, shut it off, restart then it will act properly. New fluid and filter changes nothing. 113K miles first problem. Doesnt happen all the time but at the most in appropiate ones, like on the freeway.

AAA Autocare replaced my transmission in my Dodge Charger in August 2014. Recently my starter went out and I took it back to AAA Autocare, the technician says that the transmission was put in wrong or maybe not aligned, could it be the reason my flywheel is damage?

As I hit the brakes sometimes my oil pressure light comes on or even if I turn the wheel all the way it does it as well.

seems ok on connections, all been ok ,maybe in switch or ignition?