20
questions

Only get up to 55mph

my son wrecked it and the wheels are not straight,it would sometimes be hard to turn,it would make a squilling sound when turning, driving and the steering just went out? What should I check for?

Took four floor bolts out. Last one hooked to hump in the center of car. Head of bolt under track.don't know how to get to it. Any suggestions?

I have 4x4 what do I have to change, 98 has 95hp and 2001 to 2004 has 155hp

reverse used to work but now it does not responds when i put it. it is a 4 cylinder 1.6 engine chevrolet tracker 1998. i really want to know what i can do to remedy the reverse probelm

Radio & lights come on just fine, but the key just turns in silence or a little squeak once in awhile.

I think clutch whent out but would like to look at slave first

my car make a knocking sound that is coming from the left side of the pistons. If you are looking from under the hook. It smokes when you crank it up and it is using oil also.

I;ve repaired it once prior, can I( just take it out of the system?

on start up in morning and when it cold.

I HAVE CHANGED EVERY THING I CAN SENSOR VALVES CLEANED EVERYTHING REALLY GOOD WHAT DOES IT TAKE TO KEEP THIS CODE FROM COMING UP MOTOR RUNS FINE ,JUST THE FACT OF THE LIGHT COMING ON EVERY TIME FOR NOTHING CANT TELL WHEN SOMETHING ESLS IS WRONG CUZ THIS COODE KEEPS COMING UP WHAT CAN BE CAUSING THIS?

i have manually checked the egr and the engine stumbled but did not die it dropped for 800 rpm's to 400 rpm's and it wanted to die seems like, and was told my passages are ok but i'm not sure, the system seems ok and it runs fine, i replaced the egr valve and o2 sensor and have been performing several test checking all the hoses and the all checked out ok, should i turn my interest to wiring or solenoids or some thing else ?

ive replaced the egr valve and o2 sensor and the cel came back on after the 50 miles i comes up with a malfunction code how can i fix this is there some thing else i can clean cause im running out of time

will a weak battery or low oil cause my service engine soon light to come on or is it in need of a oil change, I'm new to Chevy's and I'm just curious it runs fine just a weak start due to battery cause i boosted it off and it started fine its just an old battery

My 1998 chevy tracker is not engageing the front axle. The air pump works, I've turned on the key with shifter in 4X4 and can hear the air pump run for less than 5 seconds. Should indicate presure is up. So what is next. Can I replace the air system and install manual hubs? How?