Replace all gaskets on a 308 engine

I have a 1980 camaro, I keep losing engine oil, its not going out the tailpipe, I can't see any leaks, but when I checked my rad, it was full of oil. The rad has a transmission line cooling the tranny and this site says that if the head gasket is leaking it will cause radiator fluid to go into the engine oil, so I was wondering if anyone has had this happen before and could dissect my problem before I sink money into fixing the wrong part

when I start the car and put it in neutral it coasts forward. and in reverse it fights itself forward and reverse. it seems to always be in forward gear. I thought I put the gasket on right. did I plug something our put the pump gasket in wrong.

Started engine had no tranny fluid flowing pressure. Thought maybe I didn't seat torque converter so I pulled tranny out and made sure it was seated. Think maybe I didn't have it right the first time. Still no pressure. Could I have damage it? If I take it to a tranny shop what should I tell them.

what kind of price should I be expecting for a valve job on a 1989 camero V6 2.8 ltr MPFI?

when setting the timing on a 1989 camero rs 2.8 V6 MPFI using a timing light.(after disconnecting the EST) Is the notch on the harmonic balancer the actual TDC or is it the white line just to the right of the notch? Haynes manual says to line it up to the notch but the white line looks like it is factory painted. Its a 2 degree difference depending on which one is used. Also do u know the factory setting for that engine the VECI label (under the hood) says 10 degrees BTDC mechanics on some camero websites are saying factory setting for this engine is 6 degrees? just wanted to get your thoughts on this thanks for your help.

All I know is above and I was curious about the possible problems and the average cost of repair

how many 12oz cans of 134a refrigerant should be added to a a/c that needs recharged after sitting for a little over a year. was recently converted over from old unit not long before it sat. no known leaks worked and blew really cold before it sat think it just needs recharging how many cans would u recommend? (its actually a 1989 camero with 2.8 V6)

recently bought a 1989 camero RS that had been sitting for a year or so. Had quite the time getting it running but with some help from u guys I finally did yeeeeeey :-)thank u for the advise it was very helpful and it runs very well now. but now I have moved to the brakes. Calipers were locked up on rotors and caliper pistons locked up as well. Got them off and got new calipers and pads for front, rear drum brakes seem to work ok. blead the rears fine but cant get any bleed out of either front brake about to check lines after it stops raining other than that what else could cause this problem? if the rear work booster should be ok right? don't know to much about brakes lol any ideas will help thanks.

recently bought a 1989 camero rs 2.8 MPFI that had sat for 1 yr but ran before that. it cranked but wouldn't start (started with carb cleaner spray but would immeditly die)fuel pump didn't run checked relays,fuses ect. changed out FP,new plugs (still nothing) was giving me a MAF code got new MAF sensor and relay ,code went away but still not starting. Seemed like it wasn't getting fuel did fuel filter (with the FP)checked fuel feed and return lines and checked fuel pressure getting 43lbs (book says 34-47 lbs)just dosent seem like injectors are firing was going to check them tomorrow wanted to see if anybody had any ideas?

my ? is actually about a 1989 camero RS coupe with a 6 cyl. 2.8 car was sitting for a year but ran fine before that starts when carb cleaner is sprayed in air intake but dies out. I didn't hear fuel pump running checked fuses, rely and elec. curcit all fine changed out fuel pump which is now pumping fuel but I broke the ventilator valve assembly/fuel tank vent valve (Haynes book calls it ventilator valve assembly)(looks like a little canister with only one end attached to a hose)cant find the part anywhere they say its discontinued. Would this keep the car from running/starting? will engine run without it?

When i turn key to start car it runs when i let key go to run posistion it stops

I have replaced the cat. conv. and car ran great for a day, then I completely cleaned the throttle body and again it ran great for a day. I replaced the MAP sensor due to a 33 code and nothing. The car tries to start but dies, applying gas makes starting even harder. When it does start it runs very rough and dies almost immediately.