1990 Chevrolet Camaro Questions

All 1990 Chevrolet Camaro Questions

Ask a Question
I have a 1980 camaro, I keep losing engine oil, its not going out the tailpipe, I can't see any leaks, but when I checked my rad, it was full of oil. The rad has a transmission line cooling the tranny and this site sa...
when I start the car and put it in neutral it coasts forward. and in reverse it fights itself forward and reverse. it seems to always be in forward gear. I thought I put the gasket on right. did I plug something our ...
Started engine had no tranny fluid flowing pressure. Thought maybe I didn't seat torque converter so I pulled tranny out and made sure it was seated. Think maybe I didn't have it right the first time. Still no pressur...
what kind of price should I be expecting for a valve job on a 1989 camero V6 2.8 ltr MPFI?
when setting the timing on a 1989 camero rs 2.8 V6 MPFI using a timing light.(after disconnecting the EST) Is the notch on the harmonic balancer the actual TDC or is it the white line just to the right of the notch? H...
All I know is above and I was curious about the possible problems and the average cost of repair
how many 12oz cans of 134a refrigerant should be added to a a/c that needs recharged after sitting for a little over a year. was recently converted over from old unit not long before it sat. no known leaks worked and ...
recently bought a 1989 camero RS that had been sitting for a year or so. Had quite the time getting it running but with some help from u guys I finally did yeeeeeey :-)thank u for the advise it was very helpful and it...
recently bought a 1989 camero rs 2.8 MPFI that had sat for 1 yr but ran before that. it cranked but wouldn't start (started with carb cleaner spray but would immeditly die)fuel pump didn't run checked relays,fuses ect...
my ? is actually about a 1989 camero RS coupe with a 6 cyl. 2.8 car was sitting for a year but ran fine before that starts when carb cleaner is sprayed in air intake but dies out. I didn't hear fuel pump running check...
When i turn key to start car it runs when i let key go to run posistion it stops
I have replaced the cat. conv. and car ran great for a day, then I completely cleaned the throttle body and again it ran great for a day. I replaced the MAP sensor due to a 33 code and nothing. The car tries to start ...
it is leaking fuel while just sitting. removed the MAF sensor and fuel had been running through it down into the air filters the car was getting hard to start but i have sense disconnected the battery and it is stil...
It's only on the left side of motor manifold and carb are stained looks brownish in color back left corner of motor by spark plug wet with oil/antifreeze also under car .does it sound like gasket of crack block
I need xtra keys because of all the people that drive the car and at $54.00 a pop it will get expensive!