22
questions

after it slowed to 5 mph put it in park, now engine is extremely loud like its going to blow up and no oil left

Vehicle has very high idle

Going up a hill I had gas pushed down for power, service engine light came on, and it felt like less power. Once at a stop it was sputtering like it was going to die. Parked and idling it will go from high to low and lightly sputter when it's in low idle like it will die, but it won't. I turned it off for 15, and tried to start it again, service light went off but it almost didn't turn over. Drove it a few days later, still idling high and low, but felt okay while driving 35 good power. At a stop it was sputtering. Engine is a 4Liter V6. Did the headlight alternator test, lights on and pushed accelerator and lights did not dim. Haven't been able to get it into the shop, any ideas where to start?

wont go into hi 4wheel but will go into 4lo with some troble then it wont shift easily and its hard to get it out of lo4

i have replaced trans,flt wheel,fuel pump n filter,starter, alternator,fuel inj-hoses (spider),radiator,water pump,2-freeze plugs,2- bushings,ign-module,spark plugs n wires n filters... truck runs great in drive way but when i drive n temp reaches normal level it starts bogging n when i give it more gas it turns off n will not start for 4 to 5 hrs , sometimes it will start right up n sometimes i need to get a jump . I have taken it to 2 mach shops n 1 back yard mach n the Chev dealer they ran diag on it said it was ign-mod replaced it n it still doing the same ...does any one know what it could be ???????????????

new fuel pump n filter , tranny, fly wheel, water pump , radi, cata converter, computer,spider(fuel inject-hoses)much more,its not over heating but when temp reaches normal 1/2 on gage it starts to bogg n when i give it more gas it turns off n will not start for 4 to 5 hrs , it runs great in drive way can leave on for an hr or more runs great but to drive it will turn off can any one help....? 2 mach shops n dealer can not find problem diag at dealer said it was ign-mod they replaced but still did same thing

new trans,fuelpump,filter,flywheel,spider(fuelinject) hoses, waterpump, radiator,starter,cati-converter,computer,ign-module,, truck runs great but when temp reaches normal 1/2 on gage it boggs n when i give it more gas it turns off n will not start for about 4 hrs sometimes i have to get a jump n sometimes it will just start right up like nothing wrong cant go more than a mile , it runs great n will stay on when in driveway can u help , ive taken it to 2 shops 1 backyard mach n chev dealer they put in ign-mod but still ran the same wanted to replace computer but i did a week before can not find what or why it shuts down its not over heating

When starting in the morning, it starts fine but after a minute or two the odd sputter will happen, then become more frequent, about every 30 seconds or so. After letting it warm up for about 5 minutes, it sputters when put in gear and has trouble accelerating and sometimes feels like it wants to stall and will sputter at times at stop lights. Once vehicle is well in operating temp range (above 40 C), seems to run fine.
History: 101500 kms . O2 sensor replaced 2 years ago. I had a tuneup prior to this winter and also replaced the muffler. Shop did clean the spark plugs and put in fuel injector cleaner. Seemed to work fine for about 3 weeks then same issue started again. Brought it in again an suggested catalytic converter may also be clogged. Shop checked spark plugs etc. Cat converter was replaced and vehicle was running even better, power issue up hills now gone but again, about 3-4 weeks later sputtering issue is happening once more. Just changed my air filter, did smell a bit of gas when I removed the lid, and air filter did smell gassy as well (engine was slightly warm still)
Any suggestions what may be causing the sputtering?

I HAVE A 1994 CHEVY BLAZER FULL SIZE AND THE PEOPLE THAT PUT MY DUAL EXHAUST ON DIDNT PUT A O2 SENSOR IN AND I CANT FIND ANY WIRES THAT WOULD MATCH THE O2 SENSOR I BOUGHT,I BELIEVE THE PEOPLE CUT THE WIRE OR SOMETHING SO I NEED TO FIND A WAY TO HARD WIRE THE UNIT CAN ANYONE HELP ME

this morning the window wouldn't roll up. i couldn't hear a motor or anything like that - it rolled down, and then it wouldn't roll back up. that's it. all the other windows are working fine. since i lie in cleveland and it's winter and i park outdoors, this is a PROBLEM. is it possible that ice/snow got in somehow and caused this, or is this gonna be an expensive fix?

Approx time and if possible which tools and instructions for the repair

Hi, my truck has a canister under the hood in the drivers side but the metal hose that goes to it its broken and sometimes i can smell gasoline while driving, the truck its just repaired because of an accident on the road but i think the mechanic missed this. What are the dangers of having this failure?.

My 1994 Chevy Blazer headlights will not come on parking lights still work and so do turn signals. Lights flickered the went out. any suggestions?

Right after i crank my truck and put it into drive/reverse it'll cut off, but will crank right back up. Also, while going down the road it'll skip or buck and the brake light will cut on. I've tried putting sea foam(or whatever its called) in, replacing the ERG valve and something in the distributer and it's still doing it. Anyone know what the deal is? Please let me know, it'll be greatly appreciated.