2000 Buick Regal Questions

All 2000 Buick Regal Questions

Ask a Question
I have a 2000 Buick Regal that with about 135,000 miles on it and it randomly shuts off. It will cut of once a day and sometimes 10 times a day. It starts right back up with no problem and mechanics cant find the prob...
Not slipping, no loss of power, no change in rpm, just a hard shift. Shutting the car off for 30sec and restarting fixes it. Car needs to be hot and running in city traffic for 30-40min for it to happen. Engine sounds...
After starting it and letting it run for about a min. I go ahead and put it into gear from park and it shuts off immediately.
I replaced the plugs due to fouling of fuel from tryingto start it. I also replaced the crank position sensor thinking that it was not signaling correctly. I justnow installed a TPS. Still starts and runs smoth when c...
Had new water pump & thermostat installed. Also new double platinum spark plugs & wires at same time. Now radio reads LOC, check engine soon light is on, backfire like noise when I start it ( not superloud though) , s...
need to know where and how to change the light bulb as I cannot find it inside the trunk.
please help me what i need to fix
car only runs drive 1 and reverse other gears dont work
power window motors and regulators seem to work fine,up and down perfect but if you leave them down over nite you have to jump power to the motors to get them back up.switch is glowing on drivers side makes a clicking...
to be able to turn of that light or please tell me how to turn it off or how to remove it to turn it off thakyou for your help
the service engine light came beck on so now what i need to do
I had a leak in my radiator and so I replaced my radiator with new one and new coolant,2 days later water pump went bad and so drained coolant and replaced h20 pump and had coolant level sensor light on after h20 pump...
constant misfire but it still runs and drives but gets horrible gas mileage... help? how to diagnose i think it maybe a blown headgasket around it or possibly melted ignition? if you have had this problem or can throw...