78
questions

Why do I get a clicking sound when I turn the ignition key to start the engine

I've changed , supercharger gasket, manifold gasket, intake manifold gasket, coil packs, fuel filter, , checked fuel pressure, changed the computer, , all O2 sensors are new, new exhaust and C, converter , also tranny. It's better but I still can't give it full throttle. It Boggs out , RPMs go up but won't go, I back off throttle to half and it goes. I've had 3 mechanics look at it and it cost me a arm n a leg cause they all go over the same things . Plz help

IT ALL STARTED WHEN MY KEY GOT STUCK IN THE IGNITION. JUMPED THE CAR AND REPLACED THE BATTERY. STARTS FINE JUST ERRATIC BEHAVIOR ON MY GAUGES.

The car will not go into drive. It goes into first and reverse if you put it in that number on the automatic console in the car

I recently replaced the multifuction switch on my car, however after reassemably I am unable to find where a wire connector plugs in, Its a two prong wire thats green and black. I have looked and cannot seem to find where it plugs in at. I was told its location is on the steering colum. any halp would be greatly appreciated

Was told about a tutorial on you tube showing how to "rock the engine"????

Tried playing with controls switching from AC TO HEAT, in creasing fan speed etc. After car warms up after 5 or 10 miles driving - fan starts working fine - both ac and heat. doesn't do this when its warm outside - above 40 degrees.... thanks for the help

Car was running normally, wouldnt crank or even turn over at all. Everything else is fine. Just cant seem to find a 4.750 resistor. Looked at all radio shacks. They keep asking for wattage. I dont know how to find or figure out the wattage for a 4.750 resistor.

I tried testing, checking fuses which is good, use starter fluid, the car starts then keeps shutting off, also took the filter off, blowed the lines, the fuel pump still not pumping gas from the tank.

A few months ago, I wasn't able to change the direction of the air flow coming from the dashboard. The only direction it comes from is up my windshield. And now just a couple weeks ago, I would have my air flow on high, then while driving it would suddenly stop to nothing, so I would turn the knob back to off and continue back up until I could feel air coming out again. Finally just a couple days ago, I hopped into my car to go to work and there is no air flow, except for when it is on high. I try not to keep it on high all the time while driving only because I'm afraid it'll shut off on me again and then it may never work at all. Any advice?

all at the same time? The doors were left open for a few hours as I had the windshield replaced and I'm trying not to blame the windshield repair shop... Yes I do believe in coincidences... Or should I?