69
questions

I jack the car up and I see coolant coming from some were on the engine near the oil filter housing. I changed the heater hoses,the upper intake,and the egr value. I thanking it's the heater core are a blow head gasket. Not sure. Help Please

replace the entire system.

Can this be sure to no grease in ball joint boot the tire has quit a lot of play when car is stopped and I shake it with my hands

Also I have a real bad shake in front end after I hit 45mph

my acura started stalling while driving down the road a couple days ago, also when starting the motor it will also start then stall a couple of times before it stays running. So I started looking for ideas of the problem and found this site which also informed me of the recall possibility. I was wondering if its still available at this late of date

it to be smogged my obdll reads two monitors the evap & catalyst why?

when i push the button i hear the motor. so i took my door panel off and there's not much access to the window ect.. so i can see that there is a metal wire that came out of the track and i have no clue how to fix it unless i take the window out and i can't seem to figure out how to completely take the window out????????

and changed the thermostat. what is left to do????

With steam coming from under hood and all!! Let it cool off and added water. I c no leaks but car runs hot in minutes with pressure on hose. Did I kill my car??

I just changed the EGR valve and it still is not ready. I drove my car trying to reset but still nothing.

I keep getting error code in my radio/ CD player once car battery was changed.

1997 Acura Cl 3.0
Had the clutches replaced new torque converter
now the following
first gear good
second gear goes in with a kick
third and fourth are good
Then after driving for a few minutes and its warm/hot
car goes in neutral, wont go forward, but it does go on reverse, i shut it off and it goes forward again till u stop then wont go forward again.... HELP!!!!

Oil IS CLEAN NOT BURNED CLUTCHES ARE OK
Whats is my problem??
External sensor?
Valve body?
Heeeeelllpppp!!!!!