20
questions

Bought my car and drove it for a week. Coming home one night it disengaged from the transmission. Got it towed home. Next day I tried to crank it and wouldn't crank. Tried to jump it off wouldn't crank. So I took and shifted it through all the gears about 7 times with the I gnition in the start position. After that it cranked. But i can't drive it far without it disengaging again. What could be the problem

I just wanted to know if there is a way to disable the positraction feature. It seems to be having a severe sway in the rear end at speeds above 45mph.

Can I drive the car? no other symptoms noted.

have replacement, but can't get old one off

Replaced Ignition Control Unit and the Ignition Control Module and the problem still exists. The ICM fixed it for a few months. Now It will run fine for a day or two then after being parked for a few hours won't start. Quite often it will start the next day and then run fine for a while. Two different mechanics have attempted to fix it but the problem is sporadic. The mechanics think it is not getting fire.

I got this car and got it smogged on Saturday, but on Sunday afternoon my check engine light came on. I took it to a shop and they ran a diagnostic and told me I had a bad EGR system. However with a bit of research it doesn't seem possible to pass smog with a bad EGR valve. Maybe it's just dirty or maybe it's something else? It starts up a little rough but idles and drives well, but I did notice a lack of power at low speeds on a cold engine on Monday.

my car want tell me how fast im going whats the problem

i hit a tree and the tire is bent out but the collision was not bad just enough to bust right side turn signal what would be wrong... tire rod or axel

i Have cleaned up the engine many times before and started the car but when it idles while sitting it doesnt spray oil on top of the engine it only does when you drive it??

I can't shift into park.
Driver door won't open from out side.

Port for engine light code

I have a 1994 Volvo 960. I can go out and start it right up, but after I drive it, it won't start again until an hour or two later. It is like the engine has to be completely cool for it to start. What could this be?

the timing belt snapped and I was wondering the cost

where is my oil pump located

2 days and the spark plugs were replaced and didn't help the problem