Close
157
questions

Battery light came on , then car started running hot

Notice anti freeze was low. At first the car was making a noise (exhaust) when the battery light came on the noise stopped.

What type of

I just had the drivers side power window repaired which still operates correctly. The others stopped working at the same time. Checked the fuses. Are the others controlled by a relay switch under the hood?

158,000 mi

I have replaced RETURN HOSE AND STEERING IS STILL STIFF EVERY TIME I DRIVE AND WHEN CAR IS PARKED OVERNITE

When I put the key in the ignition and it's on the "on" slot right before I actually start the car . Is the check engine and airbag light suppose to light up, and should I be concerned and what does that mean please ?

While putting gas in the tank the gas pump shuts off every couple of seconds acting as though the tank is full. The vent hoses have been checked and are ok. Called a Toyota garage and he stated it could be the evac canister. Any suggestions?

caused by going through big puddle

I drive then come back, get out, and car won't start. I turn the ignition, the music , lights and dash lights up. Car won't crank up. Come back hours later and it cuts back on again and does the same cycle.

After all of these nothing worked at all. I found my radiator to be empty and after filling it, with the cap every-time i tried to start the radiator threw water. The car has been parked since 3 months now. Belts seem to move but the car wont power up at all.

is it a chain or belt for 2004. do you need to change it with the pumpwater and when...

You answered my question about engine noise, said to use toyota oil filter, which goning to do tomorrow. What kind of oil do you use? Currently we used mobile1 full synthetic 5/30. We also used a reg oil filter with that oil. My husband swants to know what oil you use. Thanks

I would like to know if and how to set the cols start idle down. Mine is between 2000 and 2200 rpms. I understand some say it is normal as long as it doesn't remain that high for long. But, my engine is making a noise at the cold start idle that high and I want to preserve the engine, so to speak, so would like for it not to be that high. Not sure if it is the top or bottom half of engine. Could be the lifters or rods, don't know, but feel that that high of a idle first time starting is to high and not healthy for this 126K engine. Please answer this question as to setting idle.