8
questions

also replaced ignition switch(not the key tumbler but the other side) installed new battery. Volt meter only reads about 10V. when it doesnt start it acts like a start solenoid problem. Any ideas?

Have to keep foot on the gas pedal for several minutes to keep it running until the check engine light goes off.

it just died on the road. no spark. i can replace the timing belts but not sure if something major broke on the engine

when i go up hills it wants to cut out and it sort of learches forward. as long as i down shift and get a good head start, i will make it up the hill. but once im in first i cant do enymore then put the peddle to the meadle and hope i make it. is it a 02 cencer? a foul plugg? or is it something more seriouse? i think it migh me the reason my check engine light is on. but it has also been on sence i bought the car. the problem up hills, noticely started a year or two after

...to the insert the 2 bolts...I have tried everything you could think of for the past 10 hrs. the bottem one is in but the top is a hair line amiss..what do you suggest?

is one axle longer than the other causing it to not turn

makes a cracking noise in right front wheel. then it quit only will drive in 4wheel drive the drive in 2 wheel drive will not turn

Everything's fine 'til the engine warms up, then there's a plume of vapor from the tailpipe. It's definitely steam, as it smells of glycol & dissipates right away. However, the motor oil isn't milky & latte-colored.