11
questions

My service engine soon light came on. Could it be due to the fact that the plug for my fan isn't connected? When I connect the plug the fan doesn't run. But when it's disconnected it run on high all the time. There is also a strong smell coming from my car , like a mix of gas and coolant. Please help. I'm running out of options for my baby.

the engine coolant sensor has been change but it continues with the same problem. it's mostly when I stop on a red light the temperature gauge goes up the car does not overheats but not sure what is going on.

The wipers quit working. Repair shop said it came unbolted from the wiper arms. After they tightened them, the wipers would not seat in the off position. The wipers would stay on the windshield about 5 inches above the seated position. When turned on the wipers will drop down to the seated position, then sweep across the windshield and return to the "5 inch" position. The repair shop says the wiper motor is bad and needs to be replaced. It seems to be just out of sequence because it was detached from the arms. Should the initial diagnostic charge be put towards the labor of replacing/ repair

i have a 2000 Saturn SW2, a few days ago, the battery and ABS lights came on. When I pulled into a store last night and went back to my car, it wouldn't start. After I got a jump I noticed the wipers wouldn't work. After I pulled into my driveway and tried to restart the car, it wouldn't turn over

i have a 2000 Saturn SW2, a few days ago, the battery and ABS lights came on. When I pulled into a store last night and went back to my car, it wouldn't start. After I got a jump I noticed the wipers wouldn't work. After I pulled into my driveway and tried to restart the car, it wouldn't turn over

i have a 2000 Saturn SW2, a few days ago, the battery and ABS lights came on. When I pulled into a store last night and went back to my car, it wouldn't start. After I got a jump I noticed the wipers wouldn't work. After I pulled into my driveway and tried to restart the car, it wouldn't turn over

Is there a simple adjustment for this?

How do you replace the drivebelt on a Saturn 2000 SW2?

Sprayed some carb cleaner in intake but will not even start or try to start momentarily.Fuel pressure and volume good.All fuses good.Cranks good but will not start. No spark seems to be the case.Is it crank sensor or ign module? I am getting fuel pressure though. 116k miles.

The front driver window will not go up after just earlier being able to go down. The window had no problems or symptom earlier to now. Tried turning off the car and then starting the car up again, but still the window refuses to react. All the other windows work fine, so I am wondering if it is as simple as replacing the fuse. If so, which location would the fuse be located under (left panel, right panel, or under hood)? Your assistance is most appreciated. Thanks