My car would not start. But everything in my car was still working. The lights, radio, air etc.So I replaced the alternator. They returned my car, it was running hot and water was gushing from a hose. He also said that a fan would not shut off. But when he put water in the car he only put water in the plastic container under the hood. Was he suppose to put it in the radiator as well? Or does it run from that container to the radiator?

Car running hot fan not coming on what could it be?

All checks were done on Battery,Starter,and alternator. I checked if there was any codes and there wasn't none my diagnostic reader.

When I accelerate the car slowly picks up speed, the rpms shoot up around 3-4 until it catches up and then speeds up. Just had the catalytic converter replaced...the car drives well other than that..

My mechanic took for test drive, didn't happen of course. He said it could be fuel pump or any number of things. What should I do first? Not sure of engine.

It takes about 5 mins before it actually starts . It sounds like the fuel pump but when i put my ear to the gas tank i hear the pump turn on .. when i got the car it was rigged up (electricly) couple months it didnt want to start, i took it to an electrical mechanic and he made it start but the way i explained before, oh n afterci start it ,its easier to start it until the following day or as long as it stays active. If anyone has any answers or suggeztions for me i would really apprecciate it

Lines out the transmission (there a left hole and right ) and i had to order some more lines but when i finally got em days later i cant remember which line went where, can anybody help , please and thank you

Service engine light is on. Took to AutoZone for diagnostic and when it was plugged in to car, the device turned off and wouldn't give diagnostic results.

and also i have noticed lately that when im low on gas the car sputters and acts like it want to stall them comes out of it.

When accelerating my car acts like it doesn't want to go and then the check engine light begins flashing and then stays on.

Idling fine in park or neutral, once i put it in gear or come to a stop I have to keep giving it gas or it it will die. Now today it started dying like that while in neutral, I had to keep my foot on the gas to keep it runing, and a ton of smoke would come out my exaust every time i pressed the gas, also my temperature gauge showed it was getting hotter. HELP ME PLEASE!!??

changed the thermistat

First it was not taking a charge, I think the compressor may be damage but, the mechanic told me that i may have a problem with the accumulator. is there a way i can do this job or how much time does it take for a shop to do this work. thanks.