some one said the head needed repair, some said ignition coils need replace, one said fuel pump relay,

I was driving the car and it started to surge (like I was running out of gas but had a half a tank of gas) for a few minutes then went back to normal for about 20 minutes then it started doing it again then it stall.
We have checked the battery, fuel pump, fuel injector(s), vacuum lines and looses wires ( found 1 that we can't figure where it goes) along with changing out fuses and spark plugs.

Also speedometer/odometer does not work.

I had the oil changed and transmission fluid levels checked. I drove it approximately 10 min. to a gas station. It would not shift into gear going on a slight incline into the station. I had to put it into park to keep it from rolling backwards. Fluids kind of a reddish brown but not as thick as oil were ALL over the ground beneath it.

my saturan has over 200 thousand miles on it,i have been real good at keeping it running,i'm not a mechanic by far,but i took it in when things needed done,but i have no idle any more i have to keep it idleing,it runs fine once going down the road but at stop lights or any time slowing down i have to put into netural and keep it running,any ideas,can't spend any more money onit without myself trying to fix stuff,so please if u know of some things i can try,i would surly appreciate it???????

types of fluids: oil, transmission fluid, steering fluid, brake fluid,

well when i start it up it makes this sqeaking noise then it stops then goes again

my 5 speed is a throttle body the motor i got tto replace itis a
fuel injection how wold i make it work cause it wont bolt up straight across like the said 1.9 sl 1 series sochwell maybe it will but myintake is different ita a throttle body the repkacement is fuel injected how woul that work.

my cooling fan will not come on i have replaced the temperature sensor and the two wire harness and the cooling fan itself i have also checked all fuses and relays what do i do next?

Just replaced battery due to bad cold crank count. Raised it to a 650 but once replaced still wont turn over and all connections ei wipers, automatic seat belt and such are much slower than before. Not with the usual force. Anyway, what would this be a sign of? I heard if the battery was faulty it would still start with a jump. Or even a push start.... So. I don't know. Help anyone?

how do i change the headlight on 92 saturn

Wondering what could cause the car not to start. It turns over but won't fire up. Could it possibly be the spark plugs? Or even the distributor? Maybe the spark plug wires? I would get it to the shop if I could but it will not start... Help?

How many miles can I drive car without alternator working? I need to get car to shop. Thanks.

I am trying to locate the drain plug for the transmission. Is it on the driver's side? What is it near?