19
questions

My carpet in the front and back gets wet as well and the back seats

Brake lights!! The light in my back window works but my two main brake light don't. I have replaced bulbs, tried fuses, even tried new relay. Can anyone help me??

after install cars still feels like at times it wants to swerve to the right almost like there is something loose .Making a right turn it also feels like the right front tire isn't turning far enough acts like it is sliding , right tire has excessive wear on out side of tire . Need to know where to go from here.

It cannot keep up on hot summer days in Louisiana, though if I run it on inside air it can almost keep up. I was wondering if a recharge would fix it or if it might indicate a need for another repair or service. I lived in MN and NY for most of my car's first 14 years, so I never needed to have the A/C serviced previously.

once a week i add 1 cup of coolant and light goes off a friend and ex mechanic said it sounds the water pump one week ididnt have to add any

i had a clunking noise in my tranny when i was reversing or hitting first and second gear,so hooked it up to computer and it read that ihad two cylinodes bad so replaced them now i have lost reverse, and dont know what else it is had it apart again and still nothing please help

ALL THE BULBS ARE WORKING BUT DIM.TRIED CHANGING ALL THE BULBS BUT WITH THE SAME RESULT.ALMOST LIKE LOW VOLTAGE.STRANGE!DO YOU HAVE ANY SUGESTIONS

I have a problem with my idle speed, when you first start it, i will idle to 1300rpm, then quickly drop to 1100rpm within just a few seconds, not long after it will drop to 1000rpm....

Here is where the issue comes in.... it takes about 15-20 minutes for the rpm to drop to 850ish. once is there is still doesnt seem to want to drop back to 850, it will stop at 1000rpm before droping back to 850ish.

Not sure whats causing the problem. I recently rebuilt the engine, which means it has a brand new intake gasket, and TPS, filter, and hoses.

Let me say that the idle is smooth and there is no misfire. So since its smooth and there isnt any misfiring, im tempted to say its a sensor but not sure, the only sensor i can think would be the oxygen sensor not reading right.

Thanks for any input

where is the refill orifice on the transaxle of 2001 Saturn SC1 with front wheel drive, and 5 speed manuel transmission?

i can not open my gas cover.. inside relise is not working. any ideas.

My saturn jolts when it goes into gear as you drive with the transmission. My trans guy said because teh battery was disconnected could effect that. He said if I keep driving it up hills and stuff it will slip back into gear and re adjust itself. Is that true

i need detailed instructions, with pictures if possible on how to replace the gear shift cable on my 2001 saturn. what happened was i was driving i went from 2nd to 3rd gear and it snapped now the car is stuck in 3rd gear and the stick just wiggles losely

THE LIGHT DOESNT GO OFF THE AIR COMPRESSOR BLOWS WARM AIR THE COOLANT COMES ON WHEN THEN AINT FREEZE IS EMPTY WILL THE EXTENTED WARRANT COVER THE REPAIRES IM NOT DRIVING THE CAR AS MUCH BUT NEED TO IF I CAN HAVE IT REPAIRED BY THEM

it worked fine last nite, but this morning it did not. could it be a relay? it sounds like the a/c kicks in. If it needed frion wouldn't it be a gradual decline in cooling?