Suzuki XL-7 Questions

All Suzuki XL-7 Questions

Ask a Question
my car makes a vvvvvmmm sound when I push brakes I know sorry this is the closest I can think of. Sounds on the left wheel side or front middle under my break pedal. Was told not breaks or Rogers. Help please
took my car to les schwab three times. my brakes, roters are good. not sure if the noise I am hearing is coming from left tire somewhere in the middle of the break. but only when I push on the breaks you hear this hum...
After the stop leak, it stoped leaking now only cold air comes out and still need to find out what the main problem is so i can fix it?! Thank you for your time
Cause Engine light on and Dashboard Fuel level show 0 Gas
The odometer is about 160,000 Kilometer and I have changed the its ATF last week.
I took my Suzuki XL-7 out for a short drive this afternoon then parked it for lunch. I came out 45 minutes later and started it up, but it ran *very* rough for about 10 seconds then quit. I started it again but had ...
this started when the belts were loose and making noise. The noise has resolved, but even after the car is warmed up there is cold air blowing until you start to drive. If you come to a stop sign it blows cold again...
Changed all bulbs and replaced fuses. lower lights off upper light on. Not sure if this is the switch or if a wiring run has gone bad. Suzuki is not been a lot of help with this vehicle.
jump start the car off it doesn't stay on long
the noise seems to be coming from the strut mount área..like a knocking sound
When it stops squealing the heat does fine. Except when idling in which case it blows cold air and will change to heat if u idle it up. Is thus water pump?
I did originally have the Satilite radio function on the radio. Now that I want to subscribe, I can't seem to locate it. There are no Suzuki dealers nearby, and any service department fix this?
What are the steps to removing a radiator on 2004 Suzuki xl7 I cannot get to bottom hoses. Can get pass fan.
how much would a rebuilt engine cost?
When I accelerate a low humming and vibration begins, it gets loudest around 45 to 55 MPH and decreases when almost stopped. It is shifting fine but seems to have some loss of compression?
While driving on an interstate yesterday, the digital lights on the dashboard started going dim, the fan motor on the AC slowed to just moving, then the car shut off. I could not restart and had to be towed to a deale...