50
questions

My car has less than 80k on her. Battery's ok. Had it towed and they can't find anything either. They say it could be a timing chain or off it's track or maybe a compression issue, but it has never, I mean never run rough and oil/maintenance is done regular. Any ideas, and if so can you give an approximate of how much to fix. Have limited cash so don't want to put too much into a great but 14 yr old car.

Noticed gas dripping under gas tank.
Car runs good. Starts good. Has power.
Took car to a mechanic. He claims that
The fuel pump modular had gone bad or was deteriorating. What I've read about a
FPM, it's interior and a exterior leak is
Unlikely. Is this FPM bad?

Don't mean to bug just had a couple of question I'm having the exact problems on my vehicle an I try to get a new fob program to computer an they told me they couldn't even connect to it an also wanted to know how I would know if my key is chipped or not my original 1 had a black top but doesn't mean it's chipped right I've been using my spare last two years original broke an I lost it an last how to know if bcm an security passlock ignition module works please an thank you anything can help

185,000 miles. Did go over a bumpy rail crossing kinda' fast, but car ran fine & started 2X after

Can't afford a new car right now. How much are used engines?

Engine will run very rough, misfire and service engine light will flash. Had ignition module replaced 4 times in last 16 months using Napa parts. Am now being told maybe needs a dealer part. What are the chances a dealer part will actually fix the issue? Trying to figure out whether to dump more money into the car or trade it in. Thanks!

Ok first off water wa in my oil . So. Changed head gasket, and the rest from there up.car still ran, but wanted to idle rough when u stop at a light, would stall out sometimes, but if I keep my foot on gas to keep idle up it was fine. Ok so all these codes came up, so like a dummy I went out n replaced what all it said map sensor, throttle position sensor,crank position sensor,02 sensor,ignition control, coil, pluggs, fuel pump, fuel filter. Well it's still sitting in the driveway, won't start???? I hope I can get it going, my only ride. Can someone help??thanks

As I drive it will not go into the highest gear when I accelarate.

Plastic latch (?) mechanism is broken which is why I cannot fix it myself. Help with infor please!

Just bought my Saturn 2002 L100 2 months ago and having a strange problem. The front passenger floor and sometimes drivers side floor gets soaked but can't find where leak is coming from. Was hoping it was minor a/c or seal issue. Any ideas where to start looking?

The serpentine belt broken on my 2002 Saturn L100 so it was replaced. Still wont start so replaced battery. Still wont start but will turn over and acts like it is chocking to start. I am not able to find any broken wires either. Now there are some semi-fresh copper shavings I found today. Could it be the starter?

latest flash count was 27
no codes when diagnostic was read

We can shut the car off and they ( headlights) will stay on for 30 to 40 minutes. Also rear light work sometimes. We have replaced All Turn signal and tail lights

I have no way to raise up my car. Can I not just add tranny fluid or will that hurt the car?

It seems as if the clutch is chattering,but wife took car to Midas Muffler,& they diagnosed problem as some type of "module"Does anyone have any idea what this problem might be,and how much it should cost to repair?

the car suddenly started losing power and the engine shook really bad. it starts fine but will not accelerate. it seems to idle smoothly but when the accelerator is pressed the engine surges . And it seems to be backfiring when the gas is pressed.

even while depressing the brake the shifter will not come out of park. Sometimes it takes four or five attempts.

The drl light flashes off and on during the day. The high beam (blue light) light flashes off and on when used at night.

could a bad oil pump cause this problem ?

could it be the oil pump ?

i have'nt talked to them yet but this seems outragous.

I read a little bit online that some people just pulled it off. I have tried to days twisting and turning and it wont budge.

car was making whistling noise when it was cold and then started doing it all the time...now it runs hot with the same noise on a short distance

48000 0n the car and I changed the fuel filter thinking that it might be getting clogged and fuel trying to back up thru the vent. She hardly drives it but it has been a week now and the smell hasn't diassapated.

I took my car to a dealership to have the bcm replaced, but when they called me to say that it was fixed the drivers side door lock works but the other three no longer have power. They want 600.00 to replace the actuators in the doors. Does this sound right to you? It sure does not to me. They worked fine before the bcm went out. Would love some advice on this issue. I have not picked up the car yet.

I had my trunk release, door locks,interior lights, dash lights gas gauge, temp gauge, and headlight sensor all stop working at the same time. I cannot put my car into gear unless i do it manually. I smelled a very strong electrical burning smell when this happened. Checked fuses and wires but could not find the issue. Any ideas?