Like the car is going to shut off

When I attempt to choose another setting on the vent selector switch (i.e.: move from panel vents to defroster or floor board) it will spring back to the vent position. If it does catch at another position, a sucking noice can be heard. I am assuming it is a vacuum leak, but am questioning if it is the selector switch itself.

After it randomly stalls, it starts right back up with no problem. Its been doing it once a day so far for the past 3 days. Yesterday it started jerking when i go to speed up from a stop. it acted like it was on ice or something and had no traction. i would have to take my foot off the gas for a second then slowly put it back on. i put transmition fluid in last night and i think that took care of the jerking problem. i think these 2 problems are related since they seemed to both happen at once, but my dad said there not connected so im not sure. please help

it shuts down whenever and it wont hold transmission fluid it does drain right back out but we think its fine then by the time we get to where we r going its all drained out and the transmission is slipping again...anyone got any ideas on what to do?

there was oil in my spark plug sockets so i changed the velve covers and spark plug gaskets on the valve cover...so i blew the oil out with an air chuck...and i still have absolutely no acceleration even after changing the spark plugs

I have changed the transmission switch, checked the bulbs and fuse.

OBD code Po455, Large!
Cant' clear this service lite.
It appears imediatly after trying to clear, never shuts off for a second.
Car runs perfectly with 63k mi. No smell of fuel anywhere.
Would it be wise to lean towards the tank preasure switch to start the process of elimination? Thanks, Chris.

while driving down the road my car just shut off and now it tries to turn over when you try to start it but it wont turn over what could it be

my neon will die any time, usually after its already running, only once did it fail to start back up. it usually starts up, could be a couple minutes or half an hour. of course it wont do it when you want it to so cant find the problem, have check wires, fuses,timing belt,( only code that shows up says its one touth off, its not)

there is a ticking noise under the fuze box under the hood and car wont start