Car Problem Reports

Audi Q7 PCM Software Update Available to Correct Engine Misfire After Cold Start

 
Audi Q7 Problem
11 Reports
Me Too
Edit

Model Years Affected: 2007, 2008

Exhaust & Emissions Affected: 3.6L V6

Average Mileage: 67,287 mi (45,000 mi - 97,000 mi)

Verified

An engine misfire may be noted after cold start resulting in illumination of the Check Engine Light. Our technicians tell us updated powertrain control module (PCM) software is available to correct this concern.

  • Visitor,

    The engine misfires when cold. Took if the the Audi dealer and was told it was due to carbon build up engine valves. We have only been using Chevron 93 octane fuel. They want to charge $1390 to clean the valves, which is ridiculous. This seems to be a common problem with this model. Buyer beware!!!!

    Flag This
  • Visitor, , 66,700 mi

    Same as above

    Flag This
  • Visitor, , 91,563 mi

    After cold start low speed driving results in erratic RPM's and jerk/surge (mainly at speeds at/under 20 mph) problem has cause CEL to come on once with random misfire codes present. Cleared codes, CEL hasn't come back but surging is still present.

    Flag This
  • Tom TN, , 62,000 mi
     Rookie

    Faced with the same problem with misfire. Fault codes: P0300, P0301, P0302, P0304, P0305, P0306. These codes are for cylinder misfire.
    At odd times 7 at low RPM (below 3000), the engine struggles to stay at stable RPM - the tach shows the RPM going up and down. When driving there are no issues.
    Told the dealer about this some time ago; they blew me off as no problem found (perhaps there was no fault code). Ran Chevron Injector cleaner - no effect. Now contemplating what to do next. Help!

    Flag This
  • wrsmithiii, , 60,000 mi
     Rookie

    engine misfires after cold start. taken to dealer twice. Audi says need fuel injector cleaner and/or new injectors. only runs poor after cold start.

    Flag This
  • Visitor, , 45,000 mi

    Car bucks and shudders after cold start and at times when it is warm as well. I have been to the dealer three times. They put an Audi gas additive in it, claimed fuel in New England was poor. It happened again shortly. Brought it back in again, they tried the additive again and told me aggressive driving would cure the problem. It happened again shortly after the additive. Brought it back again, this time for intake valve cleaning, new spark plugs, and new coils. After 5 or 6 days, went to pick it up. Service rep went to get the car, started it up, CEL came on and it stopped running. Can you believe that? Now I am waiting to see what happens next. Must be a flaw in engine design.

    Flag This
  • Visitor, , 97,000 mi

    Engine stumbels and acts like it wont take throttle after cold start up. Cold start up meaning when car hasnt been driven for overnight period.

    Brought the car to Audi dealer initially having received Recal notice on engine misfire. Explained to dealer that the car has some form of misfire and that it stumbles after cold start up. Dealer Tech immediatley asks what grade fuel we're using. Response:93 Octane. Tech asks are you using a fuel additive. Response; No. Tech suggests that issue is a result of carbon build up on engine valves. Now have used Techron for the last 4,000 miles. No change in performance. Car still stumbels after cold start up.

    Flag This
  • Visitor, , 47,774 mi

    Car hesitates donw entire length of 4 blocks. Engine light comes on, I've taken it in to shop at least twice. They can't replicate problem. Light stays on for longer now, but goes off occasionally. Weird!

    Flag This
  • Visitor, , 52,000 mi

    Audi wantsto replace PCM

    Flag This