17
questions

This is my first car so I don't really know where some things are. I think I had it running before but I'm not sure because nothing came out but hot air. I've ran the heater before and it works fine... Any ideas?

My engine stopped running today when going down the highway at 90mph, it gave no warning of any trouble. Temp was normal, full tank of gas, engine didn't sputter or give any signs of stalling. I went to give the car more gas and noticed that the engine had died so, I slowed down to 20mph and attempted a rolling start and it will turn over but will not start... Can someone please help me... Becausevof this problem, my girlfriend and I are stranded in the middle of Wyoming, over 500 miles from home.
Wesley

I USE A HAIR DRYER TO DRY IT OUT WHILE STILL ON.STARTS FINE WHEN WARM,BUT BIT DANGEROUS HAVING HAIR DRYER IN RAIN FOR MISSES HELP HELP IN NEW ZEALAND AND NO BUGGER CAN SORT
THANKS FOR ANY REPLIES

When I had changed my battery

Fuel pump is OK but not getting electricity

old trans has two cups on each side for axle

to have it inspected to get my tags i need help thank you

how to get the nute off the half shaft

i have just bought a 98 auto mitsubishi legnum station wagon and when i put it into any gear, mainly into drive then back to park it revs to about 1500 and then goes back to idle speed is this normal as ive only had manual {stick} cars...any ideas

I took my car to a mechanic and he said I said leaks in my air conditioning on my car. How much will a Compressor,
Dryer, etc. and labor cost to get this air conditioner on my car fixed.

The AC started ticking and now only blows hot air. Wont take freon. Any ideas what might be wrong?

Ok I just had my brake light switch replaced 2 days ao. Prior to that I got my brakes done March 2010. No problems with the brakes at all. Car driving fine before my brakes lights went out. The next morning after getting switch installed I drove about 3 blocks and notice a little tightness in the brake pedal. I drove about 1 mile and the pedal became very hard. I still had power to stop but the pedal didn't go down. Then shortly after I smelled smoke and there was smoke coming from bothe front wheels. Also while I was experiencing the hard pedal when I would take my foot off the gas the car would not accelerate as normal.

I did do the booster check later on by putting my foot on the brake and starting it up and my pedal did the normal and depressed a little. I pumped the brakes after turning it off and it was as normal so I think I can maybe rule out the booster.

Would the brake light switch cause any of this?
Can it be installed wrong?
Or do you thinks its Calipiers
or Bad hose?

Battery is fine new alternator but wont stay running