72
questions

My endeavor stalled while driving. I replaced the battery, fuel pump system and crank sensor. It turns on but won't start or turn over. What else could it be? Spark plugs are good. There is nothing firing.

it will go in other drive, n, and reverse
but not park

And cleaned my gas tank but it still wont start

3 weeks ago check engine on. when to auto zone, and they had very hard time pulling the codes--machine read error. when to another place same thing occured and after trying three different scanners Oreailysgive me one code. It was oxygen sensor.. took to my mechanic and i guess he read his own test and informed me that it was another sensor as well. both replaced were replaced. one on 12/11/15 and the other on 12/14/15, took emission test on 12/17/2015.

aUTOZONE SAID THEY DID OBD IN MY CAR MAY NOT WORK AS IT WAS LOOSE.

Recently changed altanater & safety relay switch. Before the altanater was changed out it wouldn't go in any gear. It runs now but won't go into 4th gear & goes into limp mode & code says 4th gear ratio is off. How or what do I gotta do to fix it

I have a 2004 Mitsubishi endeavor with no heat, the blower works on all speeds, the air condition is cold, but no heat. I ruled out the the thermostat as the vehicle water temp is normal, raising the engine does not cause it to get warmer, whats the problem?

When driving in automatic (sport shift), the transmission will go through all gears 1-4 before it reaches 35-40 mph. If I stay within this range, it will begin "lugging" down, like the rpm's are too low in this gear. If I pop it into manual shift I am usually in 4th gear at about 1000 rpm's. It does happen in 3rd gear also. When using manual shift, there are n't any problems with it at all. No check engine light has gone on, FYI.