73
questions

It seems that when I shift into gear and into any gear it will not catch to go in drive reverse it seems to stay neutral and every once in a while before it got to this point I would shift into gear and it would take a second to catch but it runs great the transmission fluid looks fine any ideas what that could be is it the transmission going bad could it be something else??????

My endeavor stalled while driving. I replaced the battery, fuel pump system and crank sensor. It turns on but won't start or turn over. What else could it be? Spark plugs are good. There is nothing firing.

it will go in other drive, n, and reverse
but not park

And cleaned my gas tank but it still wont start

3 weeks ago check engine on. when to auto zone, and they had very hard time pulling the codes--machine read error. when to another place same thing occured and after trying three different scanners Oreailysgive me one code. It was oxygen sensor.. took to my mechanic and i guess he read his own test and informed me that it was another sensor as well. both replaced were replaced. one on 12/11/15 and the other on 12/14/15, took emission test on 12/17/2015.

aUTOZONE SAID THEY DID OBD IN MY CAR MAY NOT WORK AS IT WAS LOOSE.

Recently changed altanater & safety relay switch. Before the altanater was changed out it wouldn't go in any gear. It runs now but won't go into 4th gear & goes into limp mode & code says 4th gear ratio is off. How or what do I gotta do to fix it

I have a 2004 Mitsubishi endeavor with no heat, the blower works on all speeds, the air condition is cold, but no heat. I ruled out the the thermostat as the vehicle water temp is normal, raising the engine does not cause it to get warmer, whats the problem?