36
questions

I was driving down the road it made a clunking sound I pulled over immediately and it died when I tried to restart it the engine sounded like it was cranking but the belts were not moving what could be the problem

My car is a 1986 but I did not see that year as an option but I will appreciate your help thank you

is there an other control module that controls the charging, digital gauges, the fan motor and turn signals ?
the headlights , hazard lights work.

No spark comming out of coil.I did replace the coil.

I know the Distributor mounted TFI causes this, But the TFI is mounted on the radiator on the 1988. What can cause this problem?

Sometimes they come right back on. Other times they stay off while my headlight switch is in the on position. Could it be a fualty switch?

was hit right rear near gas tank has now little to no power cant get above 15 mph what could have caused this have a 4.6 engine
most damage in that area (this lagging started today

i have a 1990 mercury cougar 3.8 v6 its having a weird issue its like it surges when driving at higher speeds you feel a small push pull feeling, also going up hill its like i loose throttle at about 20mph then i feather the gas for a second and it comes back and this repeats at about 40mph or when i i need to pass or speed up in general i took it into my ford dealership they plugged it in told me it was the egr valve the dpfe senor and the tpi sensor wich all have been replaced still having the same issue took it back in he told me it was my altenator and fuel relay switch both replaced brand new as well still having the same issue most of my family is all mechanics and there completely stumped and this didnt come on slowly i noticed it last week on the way back from work o ive also replaced spark plugs properly gapped fuel filters hell replaced the suspension air filter oil change the works and im still confused

i need help color coding the 1973 truck ignition with the 1969 cougar switch

car may be running well,stop at light,cutoff,wont start foir 5min,then startup,run tothe nextlight and do same thing

they were dim now not working at all

My volt meter sometimes is reading to high and then it goes back to normal.Can this be caused by a loose connection or bad wiring?or bad cells in the battery?

the bracket that connects to the alternator is snug up to it and when moved mayb a centimeter room supercharcher is in the way of taking it out can i just take the top part of the supecharger off instructions would be nice but a picture with a diagram might be better need help please!!!!!!!!thank you.

my brake pedal goes to floor and you hear air coming out of the pedal area.car is hard to stop