84
questions

It has 165000 miles on it, it was sitting for a couple of years before I purchased it. After driving for a month it started making loud noise and stalling. took it to a local mechanic shop and they said engine is gone, has to be replaced. is it possible to trouble shoot all vital parts like transmission, water tank and everything else and restore the car so it will run without giving trouble? How much that kind of work can cost??

It just started doing this. Earlier today it would not start in either. After about 15 minutes it started in neutral.

Car runs great but when I just let it run in garage to keep battery up, engine will run normal then reave up and go back down. Was told possible need new valve stem seals. How much would that be and at this age I would like to keep car as I only drive 1,000 miles yearly and can't afford new car. Smog guy recommended I add "Engine Repair to new oil change. Any advice? How much $$ to fix Valve stem replace. What else could it be?Seems to need radiator fluid added more often than usual and hood is very hot after short trips. Am I looking at needing new engine? am I ? What cou

Starts with some delay initially and has stalled on highway when traffic ls moving slowly or at a stop and go condition

My car only has 132,000 miles on it. I'm servicing the transmission. How many quarts of fluid do I need and what is the best fluid to use? I will also be draining the torque converter.

I have los the only key to my 1990 Mercedes benz 300E gas. The instructions to replace cylinder required a key. how can I replace cylinder without a key

The cruise control has also quit working. The speedometer and tachometer work just fine. any ideas as to what I can do to remedy this problem, any help would be appreciated. Thank you so much.

the freeway twice, but mostly when coming to a stop or pulling into a parking spot. I paid dealer $220 for diagnostic which was not definitive. They said it "probably needed the two fuel pumps and gas filter replaced at $1200. I decided to change gas brand and put in a fuel filter cleansing solution. Now it has only cut off 2 times in the last month and only at stop signs, but I have not driven on the freeway very much. What could be the problem?

When the light is on at causes the car to start slow, have replaced both front speed sensors.

Problem mostly occurs after driving for about 15 - 20 minutes.On Freeway the transmission will go into third gear and stay there, sometimes second gear. ATF is clean and at level. Any help would be appreciated.

My W124 260-E 1988 Mercedes' central lock control electric pump needs a check out so I would like to know what is the correct amount of vaccum (mmHg) the pump should make? and what is the correct amount of air pressure the pump should make? thanks for your help.