16
questions

This is a manual trans. The handbrake problem seems to be near the handle at the console, and went from half-working to not working at all.
The cruise control system seems complicated, and has totally stopped working a year ago. Can you supply instructions for diagnosing/repairing these systems?
Thanks.

check coil, battery, spark plugs, fuses OK no
spark this a ODB 1 conector into the hood

1995 mazda . Car was running fine til all of a sudden the rmp gauge dropped the car would not shift into gear and then suddenly died as I come to a complete stop at a red light. It started fine when I got a jump box attached but died when it was taken off . I had it towed home. The next morning I had it jumped and it started it ran to work then died in the parking lot got it jumped and brought it home. Once home we took the alternator off had it tested it passed 3 times. Put it back on hooked it up and starts fine now but the windsheild wiper control does not work atall and the speed ometer works off and on. Please help I ccan't use the windsheild wipers an in Ohio its always raining

At ONE TIME BEFORE A MECHANIC WORKED ON MY CAR AND CHANGED A FEW SENSORS BUT THE CAR DIDN'T START. HE THEN REMEMBERED THAT THE SECURITY SYSTEM WAS NoT ALLOWING IT TO SPARK, OR LETTING THE GAS FLOW. How do I fix it myself so the car will start? I need to go to the hospital to get help with my back.

My engine revvs itself in neutral, overheats, I smell coolant in the engine steam, and my heat is gone. I believe it may be the intake gasket but I'm not sure.

After driving sometimes the engine will develop a ticking noise from the top. It will get progressively louder to the point where it's quite annoying. Then out of nowhere it will go away. It comes and goes with no warning and I cant figure it out. I run 10w-30 mobile 1 full synthetic and change the oil every 3000 miles. Car has total of 163xxx miles.

had replaced motor mounts. got a tune up and problem still there.

ex. spark plugs, wires, etc.

How do I learn if my engine is an interference engine.

Our 626 just started this , this yr. at first it would sometimes stall when coming to a light after driving for about 5-10 miles. Now it's doing it all the time. we've already replaced the mass air flow sensor as well as the mass air boot. still the problem is getting worse. now we just had a lot of rain and water got sucked up into the engine. we got most,if not, all of it out,but still the problem. could it be a problem in the intake manifold it self? if so, what's the best fix?

check engine light is always on