140
questions

I drove to a gas station got gas then it wouldn't start. my Lexus has 125000 miles on it. I recently replaced both knock censors.

What should be the reading of O2S B1S2?
The readings I get, at idle, temperature 190*, vary from 0.000 to 0.010 to 0.770.

The car while driving sets P0125 code first then later will set P0172. While the car is sitting still, at idle it only trips the P0172. However, leaving idle for another 5 to 10 minutes it starts setting the misfire codes (P0300, etc).

I had a check engine light come on over a month ago. My scanner said it was a P0171 $10 generic code, bank 1. So I changed the air fuel ratio sensor. The code cleared, then I had a pending code for, I think P1153 incorrect signal pulses to ECU on bank 2, so I changed the bank 2 air fuel ratio sensor. The codes reset for about a week then bingo I now have P0171 $10generic, back again. I removed the MAF and cleaned it with MAF cleaner. It is the original MAF sensor. The vehicle has 137,000 miles on it. I am retired and really do not drive it much. I bought it 6 years ago and only put 20,000 miles on it. I do change oil and filter every 4 months. The air filter I just changed. I did notice that a hose just above the filter and before the MAF sensor was off. It must have been off for since my last air filter change, which was about a year ago. I did check the intake manifold and valve body area with carburetor cleaner and I did not see any change in my idle. The idle is a little rough and you can smell a rich exhaust gas. I did check a lot of the small vacuum lines and they look okay, nothing brittle with good connections. Not sure where to go from here.
I read several articles on this subject. I am seriously considering getting some injector cleaner and adding it to my fuel, also I was going to get some fuel conditioner. The next step it to have the fuel pressure checked.
Any help would be appreciated.

Floor, and not responding when brake is applied. Took to break masters and was told it may be electrical issue and have something to do with abs?? But can't pin point and sending me to dealership?? Any ideas??

Started hearing loud noise from rear, growling/humming/?? Sound and vibration that stays constant but will level off once cruising at a set speed, and get louder if and when accelerateing. How can I determine if its hubs/bearing issue or bad tire issue, as I've read that both of these issues can sound similar. Can the average Joe do this at home, or does this need to be done in shop setting with a certified mechanic.









Is at the correct level. is there a fairly easy way to rule out possible issues and find the problem for the average car owner. Or does this need to be done in shop setting by cert mechanic?

It is still misfire ing. Check engine light. Comes on and goes off repeats

The weather was cool I turn air condition to hot, after turning back to max cool the air condition does not cool again

has no thumping sounds it runs just fine till i go over 60